4

I have a motherboard with two Ethernet ports, and I would like to get a connection on both ports. Eth0 already has a connection and can be used without problems. Eth1 however shows up as "unavailable" in nmcli. How can I make this Ethernet port usable as well?

Some related information:

ethtool eth1

Supported ports: [ TP MII ]
    Supported link modes:   10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
    Supported pause frame use: No
    Supports auto-negotiation: Yes
    Advertised link modes:  100baseT/Half 100baseT/Full 
    Advertised pause frame use: Symmetric Receive-only
    Advertised auto-negotiation: Yes
    Link partner advertised link modes:  10baseT/Half 10baseT/Full 
                                         100baseT/Half 100baseT/Full 
    Link partner advertised pause frame us Symmetric
    Link partner advertised auto-negotiation: Yes
    Speed: 100Mb/s
    Duplex: Full
    Port: MII
    PHYAD: 1
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: pumbag
    Wake-on: d
    Current message level: 0x00000007 (7)
                           drv probe link
    Link detected: yes



ifconfig eth1

eth1      Link encap:Ethernet  HWaddr F6:7B:7B:7B:E9:C2  
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)



ip addr

 eth1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000
link/ether f6:7b:7b:7b:e9:c2 brd ff:ff:ff:ff:ff:ff

EDIT:

nmcli dev status

DEVICE  TYPE      STATE        CONNECTION 
eth0    ethernet  connected    eth0       
eth1    ethernet  unavailable  --         
lo      loopback  unmanaged    --         
sit0    sit       unmanaged    --
3
  • Is it unavailable or unmanaged? What is the output of nmcli dev status? Oct 7, 2015 at 8:30
  • Also, can you confirm that unplugging the cable from eth0 and plugging it into eth1 doesn't work? Is eth1 still unavailable when you do this? Oct 7, 2015 at 8:34
  • It is unavailable, and yes, I have tried to switch cables but nothing changes.
    – Anders
    Oct 7, 2015 at 8:40

4 Answers 4

3

I was getting Connection 'eth1' is not available on the device eth1 at this time. I looked at the network cable lights and there were all off. The cable had something on one of the connectors (dirt or plastic remains) that was preventing it from connecting.

2

Please try this:

nmcli connection up id <connection name>
3
  • 1
    No suitable available connection Jul 6, 2018 at 4:21
  • 2
    "device <my device> not available because device is not available" I love it Aug 25, 2019 at 17:15
  • It works for me, how can I have it up automatically?
    – Francois
    Nov 13, 2020 at 20:47
2

For me the problem that has caused this was that the Network-Manager was not recognizing the interface because it was still configured via /etc/network/interfaces.

To solve this problem I just needed to comment out all the lines concerning the interface failing in /etc/network/interfaces and then restart the networking service with service networking restart.

Hope this will help someone

0

I see two possible reasons.

  1. You may be bitten by a bug similar to this. Try restarting NetworkManager service after you connect a cable to eth1 to confirm.

  2. It may so happen that you don't have any automatic connections for eth1, so network manager doesn't know what to do. You can run nmcli con list | grep eth1 to confirm. If no connections are listed, create one. If there are connections, make sure one of them is set up to connect automatically.

6
  • Thank you for your input. It is not the first option as I am unable to get a connection even when I have just booted up, and restarting the service changes nothing. As for the second option, I am unable to run the command as nmcli states that 'list' is not a valid 'connection' command.
    – Anders
    Oct 7, 2015 at 9:28
  • 1
    But I ran nmcli con | grep eth1 and I have set up a connection for eth1, but I get the following error when trying nmcli con up eth1: Error: Connection activation failed: Connection 'eth1' is not available on the device eth1 at this time.
    – Anders
    Oct 7, 2015 at 9:36
  • It's strange that nmcli con list is not supported on your system. I have nmcli version 0.9.4.0 which is quite old but supports the list command, and Debian stable is already at 0.9.10.0. Chances are, your problem may be fixed by a simple upgrade. Oct 7, 2015 at 9:46
  • 1
    My version is 1.0.0, don't know if that is an earlier version of nmcli or not, but I would assume it is newer.
    – Anders
    Oct 7, 2015 at 10:28
  • 1
    I'm using version 1.22.10 and there the command to list connections is simply nmcli con.
    – cloudlena
    Mar 19, 2020 at 11:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.