I have an NFS share on a server that was working fine up until a few days ago. Me and my co-worker connect to the server with our machines, and share the data we are working on. All are running Ubuntu 12.04.

I can connect fine still, but he cannot mount the shared space:

mount.nfs: access denied by server while mounting server:/shared/space

So I double checked to make sure his machine is in the server's /etc/exports file, and I also ran

$ exportfs -a

from the server, but I still get the same error when mounting.

Is there any way to compare information from his machine to information contained on the server to see why he is being denied access?

He can still SSH into the server, but he is not accustomed to using the command line, and it would be great for our whole team if he could access the server from his desktop again.

Any ideas are greatly appreciated.

coworker@degas:~$ showmount -e bic
Export list for bic:
/nfs/home degas.tmh.tmhs,picasso,nic.smab.tmh
/data     degas.tmh.tmhs,picasso,nic.smab.tmh

Server is bic, my machine (which connects fine) is picasso, my co-worker's machine is degas.

  • Check name resolution, and check forward/reverse lookups are working still. – Sobrique Oct 6 '15 at 16:28
  • Is his machine the only client? If so, have you tried service nfs-kernel-server restart? – derobert Oct 6 '15 at 16:29
  • I'm not sure if those are censored-for-privacy hostnames or not... But I notice one ends in "tmhs" and one ends in "tmh". Is that a mistake? Having the hostname wrong in /etc/exports would explain the access denied. – derobert Oct 6 '15 at 18:01
  • No, that is precisely how it appears. Interestingly, in the /ect/exports file on bic, only degas is present. This might indicate that the name resolution is functioning correctly, as Sobrique suggested to check? Edit: only degas as opposed to degas.tmh.tmhs – reas0n Oct 6 '15 at 18:02
  • 1
    @Sobrique I think your suggestion was correct, thank you! – reas0n Oct 6 '15 at 20:00

I ran

$ host

on the server, and checked the hostname of all IP addresses. degas.tmh.tmhs had a different IP address than the machine we were trying to fix.

It appears that two different IP addresses share the hostname degas. This may be because recently he had to switch internet connections. I added his actual IP address to bic:/etc/exports, ran

$ exportfs -a

and was then able to mount the shared space on his machine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.