2

I've been using Fedora 22 on my work pc for a number of months now, it works fine updated frequently with multiple kernel updates, up until a one day it's can no longer find the which or clear command.

bash: clear: command not found... 
Install package 'ncurses' to provide command 'clear'? [N/y] y


* Waiting in queue... Failed to install packages: ncurses-5.9-18.20150214.fc22.x86_64 is already installed

bash: /usr/bin/which: No such file or directory

the next time I reboot the OS will not even start, originally I would have put this down to being a beta version of Fedora but it's happen fours times now... So you anyone can help it would be much appreciated

4
  • This is really quite strange. Can you run sudo rpm -V ncurses and sudo rpm -V which?
    – mattdm
    Oct 7 '15 at 2:18
  • They both return blank
    – James Read
    Oct 8 '15 at 13:35
  • Well that's even more weird. That means that rpm believes those packages to be correctly and completely installed. Is there any extra information you can provide that might help? Anything odd about your setup or anything that changed?
    – mattdm
    Oct 8 '15 at 13:38
  • No this is my work desktop I try not to mess with it if I can help it.
    – James Read
    Oct 8 '15 at 15:13
6

Managed to actually get working after a few hours of trying different thinks.

I had to boot into the older kernel where it still sort of works remove all third parity drivers and still no clear or which by this point.

reboot into the new version of the kernel and then sudo dnf reinstall ncurses which and reinstall drivers...

I have no idea why this happen but I have my PC working again without having to flatten it again.

thanks for all your help

1
  • This is what worked for me anyway.
    – James Read
    Oct 8 '15 at 15:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.