0

I turned on the machine one day and some websites would load others not. SSH wouldn't work, gmail wouldn't work.

So I opened the my ftp client and tried to upload something and it stopped at 0.1 complete.

Pulled out some hair.

Solved the issue by plugging a network cable into the thing.

That worked for 4 days.

But now I have the exact same problem!!!

I can ping successfully from the command line. When I run a speed test the upload part fails with an error....

Is there some sort of upload port that could be closed or something?

Any idea how I can debug this issue?

2

"Upload port" has no meaning. It looks like you had a flapping connection via wifi and you solved that by connecting via Ethernet.

Since the problem has now come back, please verify that your wifi is off. Your computer might have used the Ethernet connection but now perhaps is using wifi again, even if a cable is plugged.

Check, in this order, that you can:

  • ping the loopback address 127.0.0.1

  • ping your own IP address

  • ping a machine in the same LAN

  • ping your gateway's IP address

  • ping a machine out on the Internet. Concerning this last point, try to ping an external IP address (e.g. 198.252.206.16) and its FQDN (e.g. unix.stackexchange.com); if you can ping the IP but not the FQDN, then your DNS settings in /etc/resolv.conf are wrong, and you need to add on the top of the file the correct nameserver (8.8.8.8 is Google's DNS and will work fine).

This should make you able to know where the problem lies.

  • I restarted the route, unplugged the wifi card, plugged in the cable, turned on the computer. I can ping all of the above and get a response. Now what should I do ? :) – iKode Oct 6 '15 at 13:08
  • Can you ping also a full hostname e.g. unix.stackexchange.com? – dr01 Oct 6 '15 at 13:49
  • yes I can. I have since created a linux mint boot key and booted in on that... same effect on the cable.... is it possible it's a hardware networking issue? – iKode Oct 7 '15 at 11:45
  • Yes, it looks like a problem with the firmware of your wifi card. Try to look on the Internet for the correct driver. – dr01 Oct 7 '15 at 11:51
  • I'm running from ethernet cable at the moment. Both wifi and ethernet don't seem to work. Could something have happened to the firmware on the motherboard or could it be a physical problem with the motherboard? My windows machine is running fine here on the same internet connection. – iKode Oct 7 '15 at 14:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.