2

Hello. I have a problem with my terminal: I can't open it. I have done a thing like written here

I have checked 'Run a custom command instead of my shell' and typed in 'echo Hello World'. Now I can't open terminal - whenever I try nothing doesn't apear, so I can't change back the settings. Any idea of how could I fix it?

4

There might be simpler ways around this.


In many desktop environments, you can run an arbitrary command via the GUI. A common shortcut for this is AltF2. Just run gnome-terminal -x sleep 10h.


Or: Login to a TTY (CtrlAltF1-F6). Run DISPLAY=:0 gnome-terminal -x sleep 10h.


Or: You might have another terminal emulator installed, say xterm. Run it, and then gnome-terminal -x sleep 10h.


Or:

  1. Open your file manager, and go to /usr/share/applications
  2. Find gnome-terminal.desktop, and copy it somewhere (your ~/Desktop, or ~, etc.)
  3. Edit the copy (probably can be done by right clicking and choosing Open With, and then picking an editor)
  4. Change Exec=gnome-terminal to Exec=gnome-terminal -x sleep 10h
  5. The copied file should be showing the GNOME Terminal icon. If it isn't, right click it, go to Properties and ensure that it is executable.
  6. Double-click the copy to execute it, which should launch an instance of GNOME Terminal running sleep 10h.

You now have 10 hours to undo whatever you did.

  • 1
    Thanks man, you saved me. I have opened xterm from /usr/share/applications and ran the command DISPLAY=:0 gnome-terminal -x sleep 10 Just after this a Terminal appeared. I have closed the both xterm and Terminal I tried to open Terminal again and it worked perfectly! Thank you very much for the answer. – Vilius Povilaika Oct 6 '15 at 16:28
  • 1
    I got myself into this problem too b/c I set Custom command: script ~/terminalSessions/$(date +"%Y%m%d-%T-terminal-session.txt"). I wanted to append dateTime to script's session file. Thank you – IberoMedia Sep 8 '17 at 3:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.