2

I have a secondary HDD that worked fine in Ubuntu 13.04. I had mounted in to /media/user/<some UUID>/. I could read and write files without problem. My Ubuntu installation was on a primary SSD.

I was forced to install CentOS 6.7 due to my new company policy. Now when I try to mount the drive I have issues.

sudo fdisk -l

yields

Disk /dev/sdb: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00095739

Device Boot      Start         End      Blocks   Id  System

The sudo mount -t autofs -o loop,offset=32256 /dev/sdb /secondary_hdd/ says

mount: wrong fs type, bad option, bad superblock on /dev/loop0,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so`

Then sudo file -Ls /dev/sdb yields

/dev/sdb: x86 boot sector, code offset 0xb8

And dmesg yields

sd 7:0:0:0: Attached scsi generic sg2 type 0
sd 7:0:0:0: [sdb] 1953525168 512-byte logical blocks: (1.00 TB/931 GiB)
sd 7:0:0:0: [sdb] Write Protect is off
sd 7:0:0:0: [sdb] Mode Sense: 23 00 00 00
sd 7:0:0:0: [sdb] Assuming drive cache: write through
sd 7:0:0:0: [sdb] Assuming drive cache: write through
 sdb:
sd 7:0:0:0: [sdb] Assuming drive cache: write through
sd 7:0:0:0: [sdb] Attached SCSI disk`

I did not format the secondary disk so not sure what is wrong.

Update: I tried sudo mount /dev/sdb /secondary_hdd but it does not work (must specify file system).

  • 1
    It looks like you don't have any partitions there. In any case, your mount command is wrong. What do you get for sudo mount /dev/sdb /secondary_hdd/? Why are you using loop? And why autofs? What is supposed to be there? – terdon Oct 5 '15 at 15:09
  • @terdon Thanks for helping me. I tried the above command sudo mount /dev/sdb /secondary_hdd/ before I posted the question and I get mount: you must specify the filesystem type. Hence I tried the loop method. – enthusiasticgeek Oct 5 '15 at 15:56
  • loop won't help you there, the main issue is that it looks like your drive has no partitions. You seem to have deleted them during your centos installation. – terdon Oct 5 '15 at 17:19
  • I am pretty sure I did not delete anything on that drive. Is there a way to recover data before I can reformat the HDD? If not on Linux may be on Windows/Mac? – enthusiasticgeek Oct 5 '15 at 18:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.