ssh destination: --VM : Oracle VM Virtual Box 4.3.20 --Linux installed on VM: Fedora 22 (IP: 10.0.2.15 )

ssh source: --Windows 7 Desktop

I installed putty on Windows 7 Desktop and am trying to connect to Fedora 22 VM using putty.

To make this work, I have configured "port forwarding" from Oracle VM GUI menu. enter image description here

for the "Host IP", I tried the "IPV4 Address" under "Wireless LAN adapter Connection" since I am on wifi at home. I also tried "IPV4 Adddress" under "Ethernet adapter VirtualBox Host-only Network". Finally I tried 127.0.0.1 for the "Host IP". None of these work.

Upon all of the above attempts, I receive "Connection timed out" from my putty. enter image description here

Once I can make this work, my next goal is to ssh from one VM to another VM. FYI - My second VM shows the same IP address of the first VM I put in, I am guessing I need to change the IP address of the second VM manually. Please let me know if you have any advice on this as well.

From what information you've included, I doubt this is being caused by how you're setting up the port forwards. The "Connection timed out" error roughly translates to "nothing was listening on port 22 at 127.0.0.1", not necessarily "the port forward isn't working".

I would make sure that sshd is up and running on 10.0.2.15 and accepts connections from localhost. The easiest way to check is to ssh localhost from inside the virtual machine.

Past that, I would try changing the network adapter order and/or interface metric.

Try using 127.0.0.1 port 22 in putty. Or Configure the VM to use bridged adapter.

Select VM, Go to Settings->Network->Adapter Set Attached to: Bridged Adapter

For 2nd VM make sure MAC address isn't the same as the one in the 1st VM, or edit the interface and set the static IP.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.