0

I see messages like these in my journal :

Sep 28 17:27:48 localhost kdeinit5[4476]: Qt: Session management error: networkIdsList argument is NULL
Sep 28 17:27:48 localhost kdeinit5[4476]: No DBUS session-bus found. Check if you have started the DBUS server.
Sep 28 17:27:48 localhost kdeinit5[4476]: The X11 connection broke: I/O error (code 1)
Sep 28 17:27:48 localhost sddm[250]: QProcess: Destroyed while process ("/usr/lib/sddm/sddm-helper") is still running.

As you can see systemd kills X before killing kdeinit5 which depends on Xorg, and it kills sddm before sddm-helper.

So I want to configure it to kill every thing that depends on Xorg and then kill Xorg, also to kill sddm-helper and then kill sddm.

How to do this ? and is it possible in general to configure it to not kill process Y until process Z is killed where Y needs Z to be running ?

I'm using Arch linux 64bit with the mainline kernel 4.2.2 and KDE plasma 5.

PS

While this doesn't break much, most of the time there is no problem But I'm having some stability issues facing some kernel panics on shutdown or boot and I think if those are solved then my system will be more stable.

1

The most important thing to do is go to https://bugs.archlinux.org/ and report the problem (having first checked that it's not already reported).

To fix it yourself, look in /usr/lib/systemd/system/ and find the relevant unit files (I don't use KDE so I can't tell you). You'll need to check the After, Requires, and Wants settings (particularly Requires).

If you don't see the problem there then it might not be a problem systemd can fix.

  • well I found sddm.service but nothing for KDE except some krb5 files(a disk burner for KDE) and nothing for Xorg too – niceman Oct 6 '15 at 16:26
  • Xorg is typically started by the display manager, which is also responsible for displaying the login screen and starting user sessions. Shutting down the display manager should shut down the open sessions, Xorg terminates automatically when all clients have gone, and the display manager knows not to restart it. This might just be a case of systemd being impatient. – Simon Richter Oct 6 '15 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.