1

I am creating a proof of concept distro for CentOS and for the moment would just like to install the @base and @core packages for my distro. I have my kickstart file configured to boot into a text installer, but I'm struggling to figure out how to get the installer to find my packages on my ISO.

I have found the syntax for --repo in the kickstart, but I'm not entirely sure what file I'm actually looking to reference to. I also am aware of using the createrepo command, but not sure how this would help as I have the standard repo files from the original CentOS 7 ISO and I'm not yet trying to add my own rpm's.

I have attached 2 screenshots, one of the GUI installer and one of the text installer. These should be exactly the same error, I don't have a source for my packages on my ISO. The packages are there, but I don't know how to tell the installer to find @base and @core packages that I copied over from the original CentOS ISO.

Text - installation source not setup

GUI - base repo?

edit: In case it's helpful here is my current kickstart file:

install
cdrom
text
keyboard us
lang en_US.UTF-8
rootpw --iscrypted $6$XRIetvtFyLXRFVzZ$jX7xRxsN6M.DIqwJ9DQui9ytaqK3IAzauSqB4zeRNvMKJo6xCJQAk90XIaxh.SBn0IBtyZM7ZlHK8eSk55VnG0
timezone America/Denver --isUtc

#partitioning
clearpart --none --initlabel
autopart --type=lvm

#bootloader info
bootloader --location=mbr --driveorder=sda

%packages
@core
%end
  • How did you copy over the packages from the CentOS DVD? Did you just copy the RPMs? You'd also need to include all the package and repo metadata to allow anaconda to be able to use it as a software repo, and for it to know about the yum groups (which is what @core is). – jsbillings Oct 3 '15 at 0:04
  • Yes, I just copied over the rpm's and then also the 175ddec2056.....comps.xml over to the root directory of my .iso. What are all the files that I need to have copied over from /repodata ? I eventually will need to edit these files as the eventual plan is to have my own set of rpm's in my ISO. edit: I copied over the /repodata into the iso and tried to install from that iso and am still receiving the same error. – Chudbrochil Oct 6 '15 at 20:24
0

If I understand your problem correctly... you need to reference a repo that is an iso. I'll give you a few examples that will hopefully help. So if you're installing off a cdrom you would use:

   repo --name="CentOS" --baseurl=cdrom:sr0 --cost=100

(This assumes your cdrom is sr0, its possible it could be a different device. Check /dev to be sure)

And if you're installing off a mounted iso:

   repo --name="CentOS" --baseurl=file:///path/to/mounted/iso --cost=100
  • I'm sure this is exactly what I need to add to my kickstart file, thank you, however I am still having some problems with "installation source". I think jsbillings had a point with having the /repodata transferred over as well. – Chudbrochil Oct 6 '15 at 20:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.