6

I have Windows 10 operating system on HP Pavilion laptop not very old. I have installed Linux Mint on another partition and both the operating systems work fine (I am able to use both of them).

My problem is: Whenever I turn on the laptop, I am directly taken to Windows 10 and not given an option for Linux Mint.

To boot into Linux Mint I have to each time press F9 to show boot options, and choose 'Ubuntu' after which I am shown the Linux Mint boot screen option (gives me option to boot into linux-mint compatibility and stuff) - and then choose Linux Mint 17.2 to boot in it.

After pressing F9, I get a menu -> Then I choose second option for Mint, the first is for Windows. (Can I change this priority order?)

This is the menu I get after pressing 'F9'

I have UEFI enabled (Legacy disabled) and Secure boot disabled. The boot priority is 'OS boot manager' and then USB, DISK etc. There is only OS boot manager, others are external device stuffs.

I have searched for my problem, but couldn't solve it. First I read about grub, this is my grub file I found at /etc/default/grub.

These are some of the

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Then I tried live booting from pen drive and reinstalling grub from there by some commands, but it was giving me errors. (What I understood was I mounted Linux partition and installed grub over there) I tried some more commands mounting individually 'chroot' something but it was giving /cow error.

I had this command sudo update-grub giving me following result in screen shot (which seems satisfactory :\ )

This says Windows boot manager found.

enter image description here

After choosing second option after F9 I am taken to menu where I can boot into Linux Mint as well as Windows from there (typical maroon background menu) I want this menu to appear at first whenever I start my laptop. Yes, I have fast-startup and hibernation stuff all disabled in Windows.

2

Sorry for this late answer. I faced this problem yesterday while installing Linux mint. Here is what you need to do

  1. In the bios setup(you get here by hitting f10 on my system just after switching the power button), as you have disabled the secure boot option( if you have not, then do it) go to the UEFI boot order options, select Windows boot manager(or something similar, I dont remember the name), press enter to open the sub menus

  2. Change to order of your boot loader keeping on top the Linux one( you can do this by pressing f5/f6). Save this by pressing f10. Ensure that the order is correctly saved by entering the sub menu once more

  3. Now save and exit the bios setup. That should do the trick. I again apologize for this late answer as this was my first dual boot and the very first problem I faced was this.

Good Luck.

2

It is NOT a mistake to use Linux with UEFI. All the contrary! And nowadays works perfect, offering a series of improvements and new functionality than BIOS. It's time to jump into the 21th century, anyway.

  1. When in Linux, ensure that you have a full UEFI support: On a console/terminal run the efibootmgr - it should show you a list that would include what you see in the firmware setup.
    • If you don't have efibootmgr, then your system is installed without UEFI support. Not so easy to fix, it's easier to re-install.
      1. In the list of efibootmgr you should see the "ubuntu" option, showing that you have properly installed Mint under UEFI.
    • If you don't see the ubuntu, then you installed before disabling the Legacy support and therefore it's MBR/DOS-based. I suspect this is your case. The simplest is to re-install Linux. Otherwise, you can use the grub-glue-efi, grub-install and efibootmgr to make it.
    • If you see the ubuntu option, then you'll notice that the BootOrder shows the label of Windows (e.g. Boot0005) as first. Use efibootmgr -o to change it.
  • Yes. The Ubuntu documentation recommends to install Ubuntu to match the Windows boot mode (which would be UEFI for Windows 8 and later). help.ubuntu.com/community/UEFI – wisbucky Jul 3 '18 at 7:50
1

I had a similar problem with Win 8.1/Mint 17.2 on my UEFI enabled Acer laptop. This solution worked for me: In BIOS, change the boot priority to Ubuntu. This will bring you to the GRUB menu at startup and you can then choose to boot to Mint or Windows. Hope this works for you.

  • One of the advantages of UEFI is that one does not need the "BIOS" to change the boot. The efibootmgr in Linux can do the same, without rebooting or entering the "BIOS" (By the way, there is no "BIOS" since it is "UEFI"). For what you said you can copy the order shown by efibootmgr and then rerun it as efibootmgr --bootorder 0000,0005,... to set your preferred boot order. – MiGrieves Mar 27 at 13:13
0

This worked for me when I dual booted my system which was running windows 10 with Ubuntu. I hope making few changes the command given below will work for you:-)

  1. Run cmd as administrator
  2. Copy and paste the following command

bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

  1. Restart your system. You will see the GRUB menu.
-3

Your biggest mistake was to install Linux in UEFI. While Windows works fine in both UEFI and Legacy/BIOS mode, Linux is much better off in Legacy/BIOS mode. Some people advise you to install Linux in UEFI mode, it does work sometimes, but sooner or later you are going to run into problems. Best solution is to use 2 separate physical drives, one for Windows, one for Linux. If that is not an option, as is the case for most laptops, what I do is start with a clean, empty unformatted drive, format and create partitions for both Windows (NTFS) and Linux (ext4 and swap) with GParted, which I use from a Live CD/DVD/USB of Linux. Next step, I always install Windows first, from a DVD or USB installer, force it to install in Legacy/BIOS mode, and after all Windows updates are done I install Linux in the previously created ext4 partitions. Since I assume your Windows was factory installed, as it is the case with all store bought desktop and laptop computers, you would need to shrink your drive "C" in Windows in order to create space for Linux. After that, boot from Linux Live CD/DVD/USB and create ext4 partitions and swap space for Linux, then proceed to install Linux. The Linux bootloader GRUB2 will see your Windows partition and include it in the boot menu options. DO NOT repair your Windows bootsector (bootloader) as it will screw up GRUB.

  • 1
    I downvoted your answer. There is absolutely no plausible evidence that Linux "is much better off in Legacy/BIOS mode" than on a UEFI platform. – fpmurphy Oct 25 '17 at 3:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.