0

I install tmux via apt-get. When I type tmux, it acts like first $ clear and then open another bash, I can not see any render borders as usual nor to split or create any windows or panes. Then I type tmux ls, it shows 0: 1 windows (created Fri Oct 2 19:26:26 2015) [193x44] (attached).

BTW, I'm using xshell to ssh login that machine.

2
  • What happens if you tmux a after the tmux?
    – tripflag
    Oct 2, 2015 at 10:00
  • @tripflag sessions should be nested with care, unset $TMUX to force
    – Jon
    Oct 2, 2015 at 10:19

1 Answer 1

1

Alright, so tmux did start and you are inside the session... The only option I can think of is that your installation comes with non-standard settings that hide the status bar and uses another prefix key for commands. Try putting the following in ~/.tmux.conf and see if things work better after a killall -9 tmux:

set -g pane-active-border-style fg=green
set -g pane-border-style default
set -g prefix C-b
set -g status on
set -g status-bg green
set -g status-left "#(cat /proc/loadavg)"
1
  • One more error is that tmux can't preserve the current working directory when creating new pane or window. I add these commands in the conf but still not working:bind '"' split-window -c "#{pane_current_path}" bind % split-window -h -c "#{pane_current_path}" bind c new-window -c "#{pane_current_path}"
    – Jon
    Oct 3, 2015 at 2:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .