1

I am building a custom ISO for CentOS 7 and for now I am just intending for this to be an absolute minimal install (a proof of concept basically).

I am re-creating the ISO via using mkisofs. The command I entered is:

Mkisofs –o custom.iso –b isolinux.bin –c boot.cat –no-emul-boot –V ‘CentOS’ –boot-load-size 4 –boot-info-table –R –J –v –T isolinux/

This successfully created the iso and allowed me to mount it in the optical drive of VirtualBox. Upon installation I am receiving an error within the rdsosreport.txt that says:

localhost dracut-initqueue[581]: Warning: Could not boot.

localhost dracut-initqueue[581]: Warning: /dev/root does not exist

So far I have: copied .treeinfo, .discinfo into the root directory of where I am making the iso. Created subdirectory /isolinux with all the /isolinux data from the latest CentOS-7-x86_64-Minimal-1503-01 as well as the /images and /LiveOS directories. I have also copied over the repo .xml file into the root directory.

I have tried a multitude of kickstart files, but the current version I am using is ultra-minimalistic just to get this to work at some point.

install
cdrom
text
keyboard us
lang en_US.UTF-8
rootpw --iscrypted $6$XRIetvtFyLXRFVzZ$jX7xRxsN6M.DIqwJ9DQui9ytaqK3IAzauSqB4zeRNvMKJo6xCJQAk90XIaxh.SBn0IBtyZM7ZlHK8eSk55VnG0
timezone America/New_York --isUtc
clearpart --none --initlabel

%packages
@core
%end

My ks.cfg is located in isolinux/ks/ks.cfg and when I boot into the system I am running is linux inst.ks=cdrom:/dev/cdrom:/ks/ks.cfg

I'm a little lost on where to investigate further as all I am trying to do is load a very simple kickstart file to get Linux to do a one-button install. I don't necessarily need to be told, just to be pointed in the right direction as I've tried quite a few different kickstart configurations and have come up with the same error.

edit: I have gotten this working by editing the isolinux.cfg file and changing the volume ID to my -V volume ID set in my mkisofs and then selecting this menu option when doing my installation.

append initrd=initrd.img inst.stage2=hd:LABEL=CentOS quiet inst.ks=cdrom:/dev/cdrom:/ks/ks.cfg

I have other errors within the iso that I'm investigating now due to the fact my kickstart file is so barren.

0

If /dev/root exists in the master filesystem and if the related device is not expected to be dynamically created at boot time, you may be a victim of a mkisofs that is not the correct mkisofs and works not as expected.

I recommend to first check this:

find isolinux/ -name root -ls

to verify whether /dev/root is in the master and then call:

isoinfo -i custom.iso -R -J -find -name root -ls

to verify whether the ISO image contains /dev/root as well.

  • /root is not in the /isolinux directory on either the iso or the master. Guess I'm slightly confused where this would even come from, when I view the .iso for the stock CentOS-7-x86_64-Minimal-1503 there isn't a /root directory either. – Chudbrochil Oct 2 '15 at 16:21
  • Why do you look for /root when you are interested in /dev/root? – schily Oct 2 '15 at 16:51
  • /dev/root isn't there either. – Chudbrochil Oct 2 '15 at 18:31
0

As a side note, any time you see dracut (like your dracut-initqueue) it means that you're in your initrd. The initrd is a small image that gets loaded into RAM that is responsible for mounting your root partition, then switches to it and calls init. My guess is that your inst.stage2 specifically is what fixed your issue, it tells the initrd where to find the root partition (the partition labeled "CentOS").

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.