1

After upgrading to debian jessie I abandoned the proprietary nvidia drivers and switched to nouveau.

  • I am using grub2 to boot.
  • Kernel is 3.8.2 compiled from source.
  • my graphics card is an nvidia GeForce 8800GT
  • The resolution of my monitor is 1920x1080

The grub menu is displayed licely and in high resolution.

My problem is the screen resolution of the initial boot messages. Later in the boot process the resolution changes to the better (I assume this is when the nouveau module gets loaded) and everything is fine, including the fonts of the text consoles.

To get the initial messages in high-resolution I apparently need a framebuffer device. Using vesafb works, but there is still a blank screen temporarily, when the nouveau driver loads.

In the old days and using the proprietary nvidia drivers I could have a vesafb compiled into the kernel and get high resolution boot messages. Now it appears I only have the choice between:

  • using a VGA console, which gives me low resolution and consequently huge boot messages until nouveau loads
  • using vesafb which gives me acceptable resolution but a blank screen during the hand-over from vesafb to nouveau.

Apparently there is no way to have nouveau compiled into the kernel to have it available right from the start. I also don't quite understand why nouveau cannot live with a vesafb while the proprietary nvidia drivers can.

update 05.10.2014

Meanwhile I managed to compile nouveau into the kernel. My problem was, that nouveau depends on some other feauture, which I had chosen to compile as a module. When I changed this, I got the option to compile nouveau into the kernel as well.

Now things are almost okay. I have the same resolution all the way throught the boot process. Only problem is that I don't see the first two seconds at all, things like

[    0.099994] pci 0000:00:1c.5: BAR 9: assigned [mem 0xfa900000-0xfabfffff pref]
[    0.099994] pci 0000:01:00.0: BAR 6: assigned [mem 0xf7000000-0xf701ffff pref]
[    0.099994] pci 0000:00:01.0: PCI bridge to [bus 01]

are missing. Not sure if this is solvable all.

  • have you tried using nvidiafb ? It is turned on via CONFIG_FB_NVIDIA and you can find it during kernel config at Device Drivers -> Graphics Support -> Frame Buffer Devices. This may conflict with nouveau though. – casey Oct 2 '15 at 20:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.