3

I would like to install aria2c on centos7. I tried with yum install aria/aria2/aria2c but I receive "no package available". What is the proper way to install aria2c on centos7?

  • Were you able to solve the problem? If so, please mark it as answered, otherwise, please let us know what failed. Thank you! – Jeff Schaller Oct 5 '15 at 14:39
  • @JeffSchaller I solve the problem by building aria2c. I followed the steps from here( from section How to build): aria2.sourceforge.net/manual/en/html/README.html) – florin Oct 6 '15 at 10:26
  • Error getting repository data for rpmforge, repository not found – lindexi Apr 13 '17 at 2:55
  • If any of the existing answers solves your problem, please consider accepting it via the checkmark. Thank you! – Jeff Schaller Apr 23 '17 at 12:50
7

On CentOS 7.2.1511, I was able to install it through the EPEL repository:

$ yum install epel-release -y
$ yum install aria2 -y
1

Under the assumption that you've tried yum install aria2 (instead of the literal yum install aria/aria2/aria2c command you listed), the Install Aria2 (Command-line download manager) on RHEL/CentOS and Fedora linux page suggests the following command:

yum --enablerepo=rpmforge install aria2 -y

If you need the rpmforge repo, you can apparently get it with either:

64-bit:

sudo rpm -Uvh http://pkgs.repoforge.org/rpmforge-release/rpmforge-release-0.5.3-1.el6.rf.i686.rpm

or for 32-bit:

sudo rpm -Uvh http://pkgs.repoforge.org/rpmforge-release/rpmforge-release-0.5.3-1.el6.rf.x86_64.rpm
  • Your assumption was correct. I tried this method but did not work: after these steps I still received the the message "no package available". – florin Oct 6 '15 at 10:24
  • Interesting; that's what I get for not using CentOS; according to pkgs.org/centos-7/epel-x86_64/…, the EPEL repo has an "aria2" package, in case it helps. 1. Download the latest epel-release rpm from dl.fedoraproject.org/pub/epel/7/x86_64 2. Install epel-release rpm: # rpm -Uvh epel-release*rpm 3. Install aria2 rpm package: # yum install aria2 – Jeff Schaller Oct 6 '15 at 13:41
  • The rpmforge urls are down. Anyone knows the valid url? – BTR Naidu Aug 5 '16 at 13:10
  • @Jeff Schaller: the step 3 does not work. It still fails to find the aria2 package. – BTR Naidu Aug 5 '16 at 13:15
0

RPMforge repository is dead and no more maintained, the only way to install aria2 command-line download tool on CentOS or RHEL distribution from EPEL repository, as shown here - https://www.tecmint.com/aria2-multi-protocol-commandline-download-tool-for-linux/.

# yum install epel-release -y
# yum install aria2 -y

The available version is 1.18.0. So in this case you might need to compile and install the latest 1.34.0 from the source package as shown here.

0

Just try:

  1. wget http://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
  2. rpm -ivh epel-release-latest-7.noarch.rpm
  3. yum -y install aria2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.