2

I use the latest Archlinux and stumpwm as my window manager with some Gnome goodies on the side (gnome-power-manager, gnome-settings-daemon and networkmanager applet). I tried to make Conkeror my default browser. I tried gconftool-2 and changed the /desktop/gnome/url-handlers/http(s) to conkeror %s with no luck.

From what I understand Gconf is migrating to GSettings in Gnome 3 but I am completely lost as to how to configure it. I logged in to a gnome-shell session and tried to change the preferred applications but the only available choices are FireFox and Epiphany. I've being googling for the past 2 hours without luck and resorted to the hardcore solution of symlinking /usr/bin/firefox to /usr/bin/conkeror.

Can anyone point me in the right direction?

1 Answer 1

2

I'm not sure if this is the proper way to do it, but it worked for me:

Make sure /usr/share/applications/conkeror.desktop contains something like the following:

MimeType=text/html;text/xml;application/xhtml_xml;x-scheme-handler/http;x-scheme-handler/https;

then run

$ sudo update-desktop-database

and finally go to System Settings -> System Info -> Default Applications. Check the available applications for "Web"--Conkeror should be listed.

2
  • Thank you, I'll try your solution as soon as I decide to install gnome on my system again. Very disappointed with the "one size fits all" approach of gnome 3. Very happy with arch and stumpwm.
    – Stefanos Klironomos
    Jul 8, 2011 at 8:38
  • Thanks!! This was driving me crazy. (Seems like it was much easier on earlier versions of Ubuntu....)
    – jon
    Jan 23, 2013 at 21:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .