3

I installed xfce4-screenshooter-plugin on my xfce VirtualBox Debian 8 and. with use of xfce4-screenshooter --help I bound PrScr and Ctrl + PrScr to capture full screen and active window screenshots respectively:

image description

This can be done in Settings->Keyboard->Application Shortcuts. However when I use this, as well as when I just run the command, clipboard contains data that neither MSPaint on real machine (I'm using VirtualBox), nor GIMP (running in the VirtualBox) can process. When I paste, I get loading cursor animation. MSPaint eventually shows this dialog:

image description

GIMP just silently fails and pastes nothing. ClipMan, however, has no problem reading the image and showing it in history:

image description

If I click that history item, the image is no longer corrupted and can be pasted in both image editors.

I just wonder: what's wrong? Is there something I need to configure or is just the plugin broken?

Edit:

Based on comments I tried another plugin, this is output of Gnome screenshot utility:

XXXXX@debianvirtualbox:~/$ gnome-screenshot -w -c
** Message: Unable to use GNOME Shell's builtin screenshot interface, resorting to fallback X11.

Again, nothing appeared in clipboard. However if I copy something before triggering the command it's gone when it terminates.

6
  • Have you tried Ctrl+Shift+V to paste as a new image in gimp? I doubt it will make a difference but you may as well try. Could it be that ClipMan is the problem? Have you tried pasting when ClipMan is not running?
    – terdon
    Oct 1, 2015 at 12:35
  • ClipMan is not causing the issue and is only workaround so far (just tested). But now, after restarting clipman, I can't get any screenshots in clipboard at all. Neither after shuting it down again. Oct 1, 2015 at 13:03
  • Strange. Perhaps Xfce is using the wrong clipboard and can't deal with complex data. Do you have the same issue with another screenshot program, gnome-screenshot for example?
    – terdon
    Oct 1, 2015 at 13:05
  • @terdon gnome doesn't work either. I noticed that although it doesn't put image in clipboard it manages to clean it. Oct 1, 2015 at 15:18
  • Can you edit your question to make it more ovvious what is runningwhere? (Paint, GIMP, ClipMan, xfce-screenshooter, ...) Oct 19, 2015 at 13:01

1 Answer 1

0

You could use a temporary file and then feed that to a new Gimp process, like this:

xfce4-screenshooter -w --open /usr/bin/gimp

(screenshooter will create a file in /tmp and pass the filename as argument to gimp)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.