I am able to do,

sudo apt-get install google-chrome-stable

This installs, chrome version 45 which does not support NPAPI plug-ins that is needed to run java inside browser.

I am trying to move one or two versions older, so that i can use this feature, but there is no info on net available.

In the meanwhile,

sudo dpkg-query -l "*google-chrome*"

shows only chrome 45.

ii  google-chrome-stable           45.0.2454.101-1      amd64                The web browser from Google

Does it mean, chrome doesn't allow people to use older versions?

Note: people suggesting me to use firefox for java plugin will get -ve points


9 Answers 9


I know this question is a bit old, but in case you came here willing to do this from the terminal, you can use this command:

wget --no-verbose -O /tmp/chrome.deb https://dl.google.com/linux/chrome/deb/pool/main/g/google-chrome-stable/google-chrome-stable_${CHROME_VERSION}-1_amd64.deb \
  && apt install -y /tmp/chrome.deb \
  && rm /tmp/chrome.deb

You'll need to replace ${CHROME_VERSION} with the specific version you want, which can be found here.

For those wanting to do it in a Dockerfile, you can use this:

# Check available versions here: https://www.ubuntuupdates.org/package/google_chrome/stable/main/base/google-chrome-stable
ARG CHROME_VERSION="81.0.4044.113-1"
RUN wget --no-verbose -O /tmp/chrome.deb https://dl.google.com/linux/chrome/deb/pool/main/g/google-chrome-stable/google-chrome-stable_${CHROME_VERSION}-1_amd64.deb \
  && apt install -y /tmp/chrome.deb \
  && rm /tmp/chrome.deb
  • 5
    You forgot the "-1" at the end. I just tried this URL and it works: dl.google.com/linux/chrome/deb/pool/main/g/google-chrome-stable/… You can find the complete identifiers in the link I put in my answer, just navigate over the pages until you find the version you are looking for. Commented Dec 24, 2020 at 13:07
  • 1
    you are absolutely right, adding "-1" fixed the URL. Thanks you very much for your help
    – omega
    Commented Dec 28, 2020 at 8:22
  • 3
    weird, getting a 404 for 73.0.3683.75-1 . Triple checked the version name but still not found dl.google.com/linux/chrome/deb/pool/main/g/google-chrome-stable/… a few other ones and same thing. Pretty unfortunate, was looking forward to installing it in docker Commented Feb 16, 2021 at 4:00
  • 1
    +1 for adding the -1 fixing the 404 issue.
    – blacktide
    Commented Apr 23, 2022 at 1:57
  • 4
    Getting 404. Has the URL changed? Commented Nov 13, 2022 at 22:13

See: http://www.ubuntuupdates.org/pm/google-chrome-stable

There you can found older versions. Just download the .deb you need and install it.

  • 1
    no 63.0.3239.84
    – Toolkit
    Commented Jul 29, 2019 at 11:21

The only way I found to install older version of chrome for Linux (Ubuntu), was to find the full version from here:

  1. https://www.ubuntuupdates.org/package/google_chrome/stable/main/base/google-chrome-stable?id=202706&page=1 ,
  2. copy it and construct the exact URL for Google to find it - http://dl.google.com/linux/chrome/deb/pool/main/g/google-chrome-stable/google-chrome-stable_<FULL_CHROME_BROWSER_VERSION>_amd64.deb

For example, we want to install Major Version: 85.0

In order to be able to install it, we need some standalone installer that is available in dl.google.com. The problem is that directories are forbidden and the exact URL of the file should be provided. To construct the full URL to the download file, we need to find the full version from here https://www.ubuntuupdates.org/package/google_chrome/stable/main/base/google-chrome-stable?id=202706&page=1 . If take Version: 85.0.4183.102-1, our standalone installer URL will be -> http://dl.google.com/linux/chrome/deb/pool/main/g/google-chrome-stable/google-chrome-stable_85.0.4183.102-1_amd64.deb

There's also such question in google support -> https://support.google.com/chrome/a/thread/33913561?hl=en (not answered yet)


You can't, unfortunately. Google removes all but the latest version from the PPA and from their download site.

You'll need to build your own repo of deb files to use when installing older versions.


Specific chrome browser versions are not possible using the official dl.google.com repository. Google removed old versions from the repository which leads to just have one available version (the stable), it can be also a APT issue.

This is sad because developers use specific browser drivers compatible with required chrome version. In my case the CI always fails once in a weak because google removes specific versions from the repository... really really sad T.T

  1. Go to: https://www.ubuntuupdates.org/package/google_chrome/stable/main/base/google-chrome-stable

  2. There you will find a list of current and previous Google chrome versions, for example:

    • Version: 110.0.5481.77-1 2023-02-07 20:08:57 UTC
    • Version: 109.0.5414.119-1 2023-01-24 20:10:02 UTC
    • Version: 109.0.5414.74-1 2023-01-10 20:08:20 UTC
  3. Grab the version number you want

  4. Visit the site https://dl.google.com/linux/chrome/deb/pool/main/g/google-chrome-stable/google-chrome-stable_xxx_amd64.deb replacing "xxx" section with the exact version number you've obtained in step 1. For example if we want Google Chrome version 109.0.5414.119-1 the url would look like this: https://dl.google.com/linux/chrome/deb/pool/main/g/google-chrome-stable/google-chrome-stable_109.0.5414.119-1_amd64.deb

  5. Once the download is complete, open a terminal window and navigate to the directory where the deb file is located.

  6. Install the deb file by running the following command:

    sudo dpkg -i <deb_file_name>.deb
  7. If you encounter any dependencies issues during the installation, run the following command to resolve them:

    sudo apt-get install -f
  8. Once the installation is complete, you can launch Chrome from the terminal using the following command:


Chrome 97 as Debian package for amd64 is available under https://dl.google.com/linux/chrome/deb/pool/main/g/google-chrome-stable/google-chrome-stable_97.0.4692.71-1_amd64.deb

  • I am getting 404 error now. Commented Jun 9 at 6:49

Some very old versions, between 48.0.2564.109 and 104.0.5112.102, are available at https://www.slimjet.com/chrome/google-chrome-old-version.php. See that page to see more details.

For Ubuntu 16.04 LTS, the latest one in that list works fine:

curl --insecure -L https://www.slimjet.com/chrome/download-chrome.php?file=files%2F${CHROME_VERSION}%2Fgoogle-chrome-stable_current_amd64.deb \
   -o google-chrome-${CHROME_VERSION}.deb
dpkg -i google-chrome-${CHROME_VERSION}.deb

Follow below steps and specify old the stable version you want to install.

1. Download Google’s signing key and add it to keyring to verify integrity of package
wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | apt-key add -

2. Set the repository
(For 64-bit system)
sh -c 'echo "deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main" >> /etc/apt/sources.list.d/google.list'

(For 32-bit System)
sudo sh -c 'echo "deb http://dl.google.com/linux/chrome/deb/ stable main" >> /etc/apt/sources.list.d/google.list'

3. Update package list
apt-get update

4. Install the stable version of Google Chrome
apt-get install -y google-chrome-stable=specify-chrome-stable-version -- no-install-recommends

  • 3
    this does not work since, there's only one version always, the current one. No way to get older ones. Commented Jul 16, 2019 at 16:04
  • can't downvote you, can you read the OP before posting?
    – Toolkit
    Commented Jul 29, 2019 at 11:21

You must log in to answer this question.