10

I am able to do,

sudo apt-get install google-chrome-stable

This installs, chrome version 45 which does not support NPAPI plug-ins that is needed to run java inside browser.

I am trying to move one or two versions older, so that i can use this feature, but there is no info on net available.

In the meanwhile,

sudo dpkg-query -l "*google-chrome*"

shows only chrome 45.

ii  google-chrome-stable           45.0.2454.101-1      amd64                The web browser from Google

Does it mean, chrome doesn't allow people to use older versions?

Note: people suggesting me to use firefox for java plugin will get -ve points

6

See: http://www.ubuntuupdates.org/pm/google-chrome-stable

There you can found older versions. Just download the .deb you need and install it.

  • 1
    no 63.0.3239.84 – Toolkit Jul 29 at 11:21
3

You can't, unfortunately. Google removes all but the latest version from the PPA and from their download site.

You'll need to build your own repo of deb files to use when installing older versions.

1

Follow below steps and specify old the stable version you want to install.

1. Download Google’s signing key and add it to keyring to verify integrity of package
wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | apt-key add -

2. Set the repository
(For 64-bit system)
sh -c 'echo "deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main" >> /etc/apt/sources.list.d/google.list'

(For 32-bit System)
sudo sh -c 'echo "deb http://dl.google.com/linux/chrome/deb/ stable main" >> /etc/apt/sources.list.d/google.list'

3. Update package list
apt-get update

4. Install the stable version of Google Chrome
apt-get install -y google-chrome-stable=specify-chrome-stable-version -- no-install-recommends

  • 1
    this does not work since, there's only one version always, the current one. No way to get older ones. – undefinedman Jul 16 at 16:04
  • can't downvote you, can you read the OP before posting? – Toolkit Jul 29 at 11:21
0

Specific chrome browser versions are not possible using the official dl.google.com repository. Google removed old versions from the repository which leads to just have one available version (the stable), it can be also a APT issue.

This is sad because developers use specific browser drivers compatible with required chrome version. In my case the CI always fails once in a weak because google removes specific versions from the repository... really really sad T.T

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.