3

I'm using Debian 8 with Gnome 3 on a laptop with the bluetooth that comes with the 7260ac wifi card.

50% of the time my Bose SoundLink Mini Bluetooth speaker can connect with the laptop successfully and the audio device shows up in PulseAudio.

However often it happens that the device connects, but does not show up as audio device. When that happens there is also the following dmesg entry appearing:

input: 08:DF:1F:XX:XX:XX as /devices/virtual/input/input27

Syslog shows this:

kernel: [18805.611224] input: 08:DF:1F:XX:XX:XX as /devices/virtual/input/input27
gdm-Xorg-:0[1007]: (II) config/udev: Adding input device 08:DF:1F:XX:XX:XX (/dev/input/event22)
gdm-Xorg-:0[1007]: (**) 08:DF:1F:XX:XX:XX: Applying InputClass "evdev keyboard catchall"
gdm-Xorg-:0[1007]: (II) Using input driver 'evdev' for '08:DF:1F:XX:XX:XX'
gdm-Xorg-:0[1007]: (**) 08:DF:1F:XX:XX:XX: always reports core events
gdm-Xorg-:0[1007]: (**) evdev: 08:DF:1F:XX:XX:XX: Device: "/dev/input/event22"
gdm-Xorg-:0[1007]: (--) evdev: 08:DF:1F:XX:XX:XX: Vendor 0 Product 0
gdm-Xorg-:0[1007]: (--) evdev: 08:DF:1F:XX:XX:XX: Found keys
gdm-Xorg-:0[1007]: (II) evdev: 08:DF:1F:XX:XX:XX: Configuring as keyboard
gdm-Xorg-:0[1007]: (**) Option "config_info" "udev:/sys/devices/virtual/input/input27/event22"
gdm-Xorg-:0[1007]: (II) XINPUT: Adding extended input device "08:DF:1F:XX:XX:XX" (type: KEYBOARD, id 18)
gdm-Xorg-:0[1007]: (**) Option "xkb_rules" "evdev"
gdm-Xorg-:0[1007]: (**) Option "xkb_model" "pc104"
gdm-Xorg-:0[1007]: (**) Option "xkb_layout" "us"

It seems there is a race condition, since it works occasionally. Any idea why this is happening or how I could force it to be recognized as audio device?

When I use Windows on the same laptop the speaker works everytime.

1

I've found this workaround here, I tried it and it worked for me:

Edit the file:

/etc/pulse/default.pa

and comment out (with an # at the beginning of the line) the following line:

#load-module module-bluetooth-discover

now edit the file:

/usr/bin/start-pulseaudio-x11

and after the lines:

if [ x”$SESSION_MANAGER” != x ] ; then
    /usr/bin/pactl load-module module-x11-xsmp “display=$DISPLAY session_manager=$SESSION_MANAGER” > /dev/null
fi

add the following line:

/usr/bin/pactl load-module module-bluetooth-discover

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.