0

I'm trying to boot my first custom kernel from Linus's latest repo:

During the decompressing stage I get the following error:

Could not find overlay #6 ### dt-test ### of unittest_destroy_tracked_overlays: overlay destroyed failed for #6

I have not been able to fix this - any ideas?

Note: I'm new to the kernel side of Linux and trying the eudyptula challenge so if this is easy to solve a pointer in the general direction rather than the solution would be nice.

closed as off-topic by slm Oct 21 '15 at 0:03

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – slm
If this question can be reworded to fit the rules in the help center, please edit the question.

0

I cloned a second copy from Linus and this ran without any issues - not sure what I did wrong the first time.

0

I experienced the same result when I tried upgrading my RHEL 6.7 system to a 4.2.3 kernel (to enable some work with docker and openvswitch).

I configured the kernel with make oldconfig which seems to be quite fine with the exception of device tree overlays. For some reason I don't understand yet (and admittedly haven't bothered to find out) device tree overlays do not work with my system. So my recommendation is to run make menuconfig, navigate to 'Device Drivers', then 'Device Tree and Open Firmware support' and in this submenu disable 'Device Tree Overlay' support. Then compile and install the kernel again and you should be fine.

Not the answer you're looking for? Browse other questions tagged or ask your own question.