I recently received my new hardware. I installed Ubuntu 15 but got an error with my dual screen. I downgraded to the stable 14.04 ... But still the same.

I have two monitors connected in HDMI and DVI on my GTX970 by Strix.

The two of them are mirroring themselves. I tried to go in the "Displays" preference menu, but the window shuts down with :

Sorry, Ubuntu 14.04 has experienced an internal error.

The detail reports this message : unity-settings-daemon crashed SIGABRT in g_assertion_message()

Also, the Ctrl+Alt+T shortcut does not work.

It's a fresh install, I did not do anything ... Is this the hardware ? What can I do to fix it and be able to extend my desktop ?

  • Maybe a driver problem ? Did you try installing your NVidia Graphic Card drivers before trying to configure the screens ? – Anonymous12223 Sep 30 '15 at 9:40
  • In fact, i don't even know how to do it ... On windows it was easy and now some say use repository, other use official version, sometimes you have to shut down gnome, sometimes lightdm ... I don't know which one applies to me :/ I am really new to linux – Dranna Sep 30 '15 at 9:57

It now works, not properly but it is ok.

After tweaking in the menus, i managed to reach a button where i could enable nVidia binary tested driver. The computer crashed and after a reboot the two screens were in extended desktop, but inverted (had to go left to hoover the right screen).

I tried to go in "Displays" which now works but not the "apply" button (an error says i can't apply changes).

But then i used these commands (they didn't work earlier, saying internal error) :

xrandr --output DVI-I-0 --off
xrandr --output DVI-I-0 --auto --right-of HDMI-0

And now, the terminal shortcut works an the monitors are in extended desktop mode, all i asked. I just hope that the error in the preference menu will not cause further problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.