0

I have a Sony PRS-T1 ebook reader which is based on Android 2.2. When I connect it to my PC, it shows up as two USB partitions: READER and SETTING. The latter is a read-only partition, only useful the first time you connect the Reader to a Windows PC or a Mac.

How do I stop the SETTING partition from auto-mounting?

I tried adding UUID="4EA9-C564" /mnt/tmp vfat noatime,noauto,user,defaults 1 0 in /etc/fstab but this does not prevent the partition from being mounted.

2

First find out the UUID of that USB partition:

 $ ls -l /dev/disk/by-uuid/

The name of the soft link to device of this mounted partition is actual UUID of that partition, for example:

 ...
 lrwxrwxrwx. 1 root root 10 09-07 08:07 ae44ddaa-0e0e-ee22-66b-983bc15159b1 -> ../../sdb2
 ...

so the ae44ddaa-0e0e-ee22-66b-983bc15159b1 is a UID of this partition.

Next add a line to /etc/fstab (you will need root permisions), something like this:

 UUID=ae44ddaa-0e0e-ee22-66b-983bc15159b1   /mnt/tmp        ext4    noatime,noauto,user,defaults    1 0

The most important here is noauto option which will prevent from automount.

  • 1
    This prevents automount at boot if the device is connected but not when hot-plugged. – To Do Sep 30 '15 at 10:23
  • Well, it is working for me (Fedotra 20/MATE) for many hot-plugged devices (cameras, usb sticks, external drives (both usb and esata)). I have 9 entries like this in /etc/fstab and all of them are working. – alcik Sep 30 '15 at 11:04
  • This is the line I added UUID="4EA9-C564" /mnt/tmp vfat noatime,noauto,user,defaults 1 0 and it doesn't work. FYI, the Sony reader is based on Android 2.2. – To Do Sep 30 '15 at 12:22
  • 1
    I thought I had a problem once with disabling vfat partition from automount, so I have found someone with usb stick with vfat partition, inserted it into my box. After it was mounted I found its UUID then added new line to /etc/fstab and reinserted stick and it is working - no automount for this partition. The only difference from yours line (except UUID of course) is I didn't used quotation marks ("). When I changed line and added these quotation marks, the partition started to automount again. Get rid off those " and youi should be OK. – alcik Sep 30 '15 at 14:03
  • Tried removing the quotation marks to no avail, but I found a solution. See my answer. – To Do Sep 30 '15 at 16:08
0

The solution I found is to use the Disks utility.

  1. Connect the Reader.
  2. Open Disks and select the Settings partition.
  3. Click the triple gear icon under the graphic.
  4. Select "mount options" and deselect "Automount options" AND "Show in user interface" and click OK.

This created the following fstab entry:

/dev/disk/by-id/usb-Sony_PRS-T1_Setting_148427501057252-0:2 /mnt/usb-Sony_PRS-T1_Setting_148427501057252-0:2 auto nosuid,nodev,nofail,noauto 0 0

The device does not show in Nautilus and the /mnt/usb-Sony_PRS-T1_Setting_148427501057252-0:2 folder is present but empty.

  • 1
    Basicly the same solution as mine, except using disk-id instead of UUID. Are you sure you get correct UUID? – alcik Sep 30 '15 at 16:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.