1

I'm trying to install the handbrake CLI onto my debian(wheezy) server. I've tried to imitate an answer here but it is not working.

I've added deb http://cdn.debian.net/debian wheezy-backports main to the sources list in /etc/apt/sources.list

and got the output after running an apt-get update and the actual install command:

sudo apt-get update
sudo apt-get -t wheezy-backports install handbrake

but I receive the following errors:

user@web:~$ sudo nano /etc/apt/sources.list
user@web:~$ sudo apt-get update
Hit http://mirrors.linode.com wheezy Release.gpg
Hit http://mirrors.linode.com wheezy/updates Release.gpg                       
Hit http://mirrors.linode.com wheezy-updates Release.gpg                       
Hit http://mirrors.linode.com wheezy Release                                   
Hit http://mirrors.linode.com wheezy/updates Release                           
Hit http://www.deb-multimedia.org sid Release.gpg                              
Ign http://ppa.launchpad.net wheezy Release.gpg                                
Hit http://mirrors.linode.com wheezy-updates Release                           
Ign http://ppa.launchpad.net wheezy Release                                    
Hit http://www.deb-multimedia.org sid Release                                  
Hit http://mirrors.linode.com wheezy/main Sources                             
Hit http://mirrors.linode.com wheezy/main amd64 Packages                       
Hit http://mirrors.linode.com wheezy/main Translation-en                       
Hit http://mirrors.linode.com wheezy/updates/main Sources                      
Hit http://mirrors.linode.com wheezy/updates/main amd64 Packages               
Hit http://mirrors.linode.com wheezy/updates/main Translation-en               
Hit http://mirrors.linode.com wheezy-updates/main Sources                      
Hit http://mirrors.linode.com wheezy-updates/main amd64 Packages               
Hit http://mirrors.linode.com wheezy-updates/main Translation-en               
Err http://ppa.launchpad.net wheezy/main Sources                               
  404  Not Found
Hit http://www.deb-multimedia.org sid/main amd64 Packages                      
Err http://ppa.launchpad.net wheezy/main amd64 Packages                        
  404  Not Found
Ign http://ppa.launchpad.net wheezy/main Translation-en_US                     
Ign http://ppa.launchpad.net wheezy/main Translation-en                        
Ign http://www.deb-multimedia.org sid/main Translation-en_US                   
Ign http://www.deb-multimedia.org sid/main Translation-en                 
Get:1 http://cdn.debian.net wheezy-backports Release.gpg [1,554 B]
Get:2 http://cdn.debian.net wheezy-backports Release [144 kB]
Get:3 http://cdn.debian.net wheezy-backports/main amd64 Packages [571 kB]
Get:4 http://cdn.debian.net wheezy-backports/main Translation-en [363 kB] 
Hit https://deb.nodesource.com wheezy Release.gpg                              
Hit https://deb.nodesource.com wheezy Release
Hit https://deb.nodesource.com wheezy/main Sources  
Hit https://deb.nodesource.com wheezy/main amd64 Packages
Ign https://deb.nodesource.com wheezy/main Translation-en_US                   
Ign https://deb.nodesource.com wheezy/main Translation-en                      
Fetched 1,080 kB in 9s (116 kB/s)                                              
W: Failed to fetch http://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu/dists/wheezy/main/source/Sources  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu/dists/wheezy/main/binary-amd64/Packages  404  Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.
user@web:~$ sudo nano /etc/apt/sources.list
user@web:~$ sudo nano /etc/apt/sources.list
Use "fg" to return to nano.

[1]+  Stopped                 sudo nano /etc/apt/sources.list
user@web:~$ sudo apt-get -t wheezy-backports install libdvdread4
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Suggested packages:
  libdvdcss2
The following packages will be upgraded:
  libdvdread4
1 upgraded, 0 newly installed, 0 to remove and 105 not upgraded.
Need to get 57.4 kB of archives.
After this operation, 3,072 B of additional disk space will be used.
Get:1 http://cdn.debian.net/debian/ wheezy-backports/main libdvdread4 amd64 4.2.1-2~bpo70+1 [57.4 kB]
Fetched 57.4 kB in 0s (576 kB/s)       
Reading changelogs... Done
(Reading database ... 65274 files and directories currently installed.)
Preparing to replace libdvdread4 4.2.0+20120521-2 (using .../libdvdread4_4.2.1-2~bpo70+1_amd64.deb) ...
Unpacking replacement libdvdread4:amd64 ...
Setting up libdvdread4:amd64 (4.2.1-2~bpo70+1) ...
W: Duplicate sources.list entry http://www.deb-multimedia.org/ sid/main amd64 Packages (/var/lib/apt/lists/www.deb-multimedia.org_dists_sid_main_binary-amd64_Packages)
W: You may want to run apt-get update to correct these problems
user@web:~$ sudo apt-get update
Ign http://ppa.launchpad.net wheezy Release.gpg
Ign http://ppa.launchpad.net wheezy Release                                    
Hit http://mirrors.linode.com wheezy Release.gpg                               
Hit http://mirrors.linode.com wheezy/updates Release.gpg                       
Hit http://mirrors.linode.com wheezy-updates Release.gpg                       
Hit http://mirrors.linode.com wheezy Release                                   
Hit http://mirrors.linode.com wheezy/updates Release                           
Hit http://www.deb-multimedia.org sid Release.gpg                              
Hit http://mirrors.linode.com wheezy-updates Release                           
Hit http://www.deb-multimedia.org sid Release                                  
Hit http://mirrors.linode.com wheezy/main Sources                              
Err http://ppa.launchpad.net wheezy/main Sources                               
  404  Not Found
Hit http://mirrors.linode.com wheezy/main amd64 Packages                       
Hit http://mirrors.linode.com wheezy/main Translation-en                       
Hit http://mirrors.linode.com wheezy/updates/main Sources                      
Hit http://mirrors.linode.com wheezy/updates/main amd64 Packages               
Hit http://mirrors.linode.com wheezy/updates/main Translation-en               
Hit http://mirrors.linode.com wheezy-updates/main Sources                      
Hit http://mirrors.linode.com wheezy-updates/main amd64 Packages               
Hit http://mirrors.linode.com wheezy-updates/main Translation-en               
Hit http://www.deb-multimedia.org sid/main amd64 Packages                      
Err http://ppa.launchpad.net wheezy/main amd64 Packages                       
  404  Not Found
Ign http://ppa.launchpad.net wheezy/main Translation-en_US                     
Ign http://ppa.launchpad.net wheezy/main Translation-en                        
Ign http://www.deb-multimedia.org sid/main Translation-en_US                   
Hit http://cdn.debian.net wheezy-backports Release.gpg                        
Ign http://www.deb-multimedia.org sid/main Translation-en
Hit http://cdn.debian.net wheezy-backports Release
Hit http://cdn.debian.net wheezy-backports/main amd64 Packages
Hit http://cdn.debian.net wheezy-backports/main Translation-en
Hit https://deb.nodesource.com wheezy Release.gpg
Hit https://deb.nodesource.com wheezy Release
Hit https://deb.nodesource.com wheezy/main Sources
Hit https://deb.nodesource.com wheezy/main amd64 Packages
Ign https://deb.nodesource.com wheezy/main Translation-en_US                   
Ign https://deb.nodesource.com wheezy/main Translation-en                      
W: Failed to fetch http://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu/dists/wheezy/main/source/Sources  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu/dists/wheezy/main/binary-amd64/Packages  404  Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.
user@web:~$ sudo apt-get -t wheezy-backgports install handbrake
Reading package lists... Done
W: Duplicate sources.list entry http://www.deb-multimedia.org/ sid/main amd64 Packages (/var/lib/apt/lists/www.deb-multimedia.org_dists_sid_main_binary-amd64_Packages)
W: You may want to run apt-get update to correct these problems
E: The value 'wheezy-backgports' is invalid for APT::Default-Release as such a release is not available in the sources

Here is the contents of my sources.list:

# 

# deb cdrom:[Debian GNU/Linux 7.4.0 _Wheezy_ - Official amd64 NETINST Binary-1 $

# deb cdrom:[Debian GNU/Linux 7.4.0 _Wheezy_ - Official amd64 NETINST Binary-1 $

deb http://mirrors.linode.com/debian/ wheezy main
deb-src http://mirrors.linode.com/debian/ wheezy main

deb http://mirrors.linode.com/debian-security/ wheezy/updates main
deb-src http://mirrors.linode.com/debian-security/ wheezy/updates main

# wheezy-updates, previously known as 'volatile'
deb http://mirrors.linode.com/debian/ wheezy-updates main
deb-src http://mirrors.linode.com/debian/ wheezy-updates main
deb http://www.deb-multimedia.org sid main

Latest errors:

user@web:~$ sudo apt-get update
Hit http://mirrors.linode.com wheezy Release.gpg
Hit http://mirrors.linode.com wheezy/updates Release.gpg                       
Hit http://mirrors.linode.com wheezy-updates Release.gpg                       
Hit http://mirrors.linode.com wheezy Release                                   
Hit http://mirrors.linode.com wheezy/updates Release                           
Ign http://ppa.launchpad.net wheezy Release.gpg                 
Hit http://mirrors.linode.com wheezy-updates Release                           
Ign http://ppa.launchpad.net wheezy Release                                    
Hit http://mirrors.linode.com wheezy/main Sources                              
Hit http://mirrors.linode.com wheezy/main amd64 Packages                       
Hit http://mirrors.linode.com wheezy/main Translation-en                       
Hit http://www.deb-multimedia.org sid Release.gpg                              
Hit http://mirrors.linode.com wheezy/updates/main Sources                      
Hit http://mirrors.linode.com wheezy/updates/main amd64 Packages               
Hit http://mirrors.linode.com wheezy/updates/main Translation-en               
Hit http://www.deb-multimedia.org sid Release                                  
Hit http://mirrors.linode.com wheezy-updates/main Sources                      
Hit http://mirrors.linode.com wheezy-updates/main amd64 Packages               
Hit http://mirrors.linode.com wheezy-updates/main Translation-en  
Err http://ppa.launchpad.net wheezy/main Sources                  
  404  Not Found
Hit http://www.deb-multimedia.org sid/main amd64 Packages         
Err http://ppa.launchpad.net wheezy/main amd64 Packages
  404  Not Found
Ign http://ppa.launchpad.net wheezy/main Translation-en_US       
Ign http://ppa.launchpad.net wheezy/main Translation-en          
Ign http://www.deb-multimedia.org sid/main Translation-en_US     
Ign http://www.deb-multimedia.org sid/main Translation-en
Hit https://deb.nodesource.com wheezy Release.gpg
Hit https://deb.nodesource.com wheezy Release
Hit https://deb.nodesource.com wheezy/main Sources
Hit https://deb.nodesource.com wheezy/main amd64 Packages
Ign https://deb.nodesource.com wheezy/main Translation-en_US                   
Ign https://deb.nodesource.com wheezy/main Translation-en                      
W: Failed to fetch http://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu/dists/wheezy/main/source/Sources  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu/dists/wheezy/main/binary-amd64/Packages  404  Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.
user@web:~$ sudo apt-get -t wheezy-backports install handbrake
Reading package lists... Done
E: The value 'wheezy-backports' is invalid for APT::Default-Release as such a release is not available in the sources

Can anyone help me with a solution? Forgive me as i'm trying to get to grips with CLI's!

  • That can't be everything. Please also show us the contents of any files in /etc/apt/sources.list.d. Also show us the errors you are getting now. – terdon Sep 29 '15 at 12:23
  • sources.list.d doesn't exist – cwiggo Sep 29 '15 at 12:38
  • @terdon i've added the latest errors – cwiggo Sep 29 '15 at 12:41
  • OK, you still haven't removed the PPA, that's the source of some of the errors. If you have no sources.list.d, I'm not sure where you have it. Try running grep -RH ppa /etc/apt/. That should show you which file points to the PPA. I also don't understand why you're using wheezy-backports in the first place. Why not just apt-get install handbrake? – terdon Sep 29 '15 at 12:43
  • @terdon I was researching and a lot of sources say that there is not a convenient way of installing handbrake cli to a debian wheezy setup. – cwiggo Sep 29 '15 at 12:45
1

You have a number of issues here.

  1. Debian doesn't support Ubuntu PPAs. Edit /etc/apt/sources.list and remove the PPA.

  2. You have duplicate entries. Either in /etc/apt/sources.list or in /etc/apt/sources.list.d. You need to edit the file and remove the duplicates for deb-multimedia.org. Run grep -H deb-multimedia /etc/apt/sources.list /etc/apt/sources.list.d and delete one of the dupes.

  3. You have a typo. Note the error:

    E: The value 'wheezy-backgports' is invalid for APT::Default-Release as such a release is not available in the sources
    

    You meant backports, not backgports.

  • I've added the sources.list contents above – cwiggo Sep 29 '15 at 12:15
  • I've adjusted as you said but I now receive more errors. Pleas see above. Thanks! – cwiggo Sep 29 '15 at 12:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.