2

I'm using archlinuxarm, armv7h architecture I'm trying to use add-repo but it gives me the following error:

$ repo-add test.db.tar.gz dep/python2-numpy-1.9.2-2-armv7h.pkg.tar.xz
==> ERROR: 'dep/blas-3.5.0-1-armv7h.pkg.tar.xz' is not a package file, skipping
==> No packages modified, nothing to do.

I've tried it with pacman v4.1.2-6 and v.4.2.1. It fails for every downloaded package that I haven't build myself

Just installing the package with pacman -U works absolutely fine

1
  • I'm reproducing this with Pacman 5.1.1 (libalpm v11.0.1) on x86_64, so it's not ARM-specific. Commented Dec 20, 2018 at 2:33

1 Answer 1

0

This issue happens when repo-add is unable to successfully run

bsdtar -tqf dep/python2-numpy-1.9.2-2-armv7h.pkg.tar.xz .PKGINFO

bsdtar is from libarchive package. Ensure that it's available in the PATH, and that the command above succeeds when run by hand for the package in question.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .