0

I am using using Ubuntu 14.04 as my regular OS, but from time to time I have to switch to Windows at my work. It has now happened at least twice, that after spending a few hours in Windows and coming back to Ubuntu I was unable to connect to the same wireless router.

Last time when I tried to solve it I noticed that Windows was having trouble connect as well after a few times of switching back and forth between boots. At first the windows diagnostic utility could solve it, but after a while it could not. I also reinstalled the windows driver for the network card. My last attempt that seemed to solve it, was that I switched the router from automatic channel to a different specific channel, so in the end I thought it has nothing to do with the dualboot setup. Naturally, I tried this again (set it to a different channel) but it didn't help. Both the current and the previous channel is unoccupied by other wifis (at least there are non I can see).

The network is configured to be DCHP, with reserved IP-s for the computers we regularly use here. Nobody else has a connection problem. Nor do I have trouble connecting to the wifi at home.

Does anybody have any idea what could be the cause of this?

0

It seems that the problem was caused by the DHCP reservation. I am not exactly sure why, since the MAC address are the same in both boots and the IPs were reserved to the MAC address. Probably this I am the same yet I am different thing confused the router.

The solution (which is not a really good one, since now it is not possible to lease the same IP for sure) was to take out the DHCP reservation and restart the router so the lease is removed. Possible, putting a short expiry time on the lease could solve the problem somewhat better.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.