I've just installed ArchLinux and LXDE, everything is working fine but fonts rendering is not optimal. Reading the wiki about font configuration and using external source of information, I've build the following /etc/fonts/fonts.conf file

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
  <match target="font">
     <edit mode="assign" name="rgba">
     <edit mode="assign" name="hinting">
     <edit mode="assign" name="hintstyle">
     <edit mode="assign" name="antialias">
     <edit mode="assign" name="lcdfilter">

Despite this, the font rendering is still not optimal enter image description here

What am I missing?

  • Did you use lxappearance? – cylgalad Sep 29 '15 at 8:38
  • Yes, with lxappearance-obconf plugin. – Ortomala Lokni Sep 29 '15 at 14:36

I've found the solution: The index of X font files was not created.

I discover this looking at the /var/log/Xorg.0.log log file.

$ grep /fonts /var/log/Xorg.0.log.old

[    13.492] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[    13.493] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    13.493]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    13.493] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    13.494]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").

I then run mkfontdir on /usr/share/fonts/75dpi and /usr/share/fonts/100dpi and that was solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.