4

I deleted the lib32-ncurses manually from the /usr/lib folder (I know...)

I was having issues with a compiled PHP and libncursesw.so.5

It broke Arch. So I boot from my a live cd but if I try to, mounted the partition but when trying to chroot to the root mount at /mnt I get:

/bin/sh: error while loading shared libraries: libncurses2.so.6: cannot open shared object file: No such file or directory
  • 1
    After booting from the livecd, trying copying its /usr/lib/libncurses2.so.6 into the mounted /usr/lib, then seeing if that works. If it does, you probably want to reinstall the package just to be sure. – Tom Hunt Sep 28 '15 at 16:51
  • yeah, bash needs all that jazz. symlink some other shell over /bin/sh - like ln -sf /usr/lib/initcpio/busybox /bin/sh or something. – mikeserv Sep 28 '15 at 16:51
  • @mikeserv Did it, but I'm getting the same error. – ericgramirez Sep 28 '15 at 17:03
  • 2
    well, if you did it from outside the chroot then it probably wont be / at the head of the path. Anyway, you can just use the pacman -r argument to install the package you need from without the chroot as well. pacman -r /path/to/chroot -S ncurses --force – mikeserv Sep 28 '15 at 17:09
  • @TomHunt The issue is I have libncurses5 on the live CD – ericgramirez Sep 28 '15 at 18:38
1

You are going to need to boot from an Arch ISO somehow. After that, you can probably upgrade the kernel by following Option 2: Reinstall Kernel from the Arch Linux Wiki article, "Kernel Panics". That article includes doing a chroot to the hard disk mounted by the ISO, so you can use pacman on the latest kernel you've got in /var/cache/pacman/pkg/. Look in that same directory for a version 5 ncurses package, and update it, too, while you're at it.

  • Sure, I'm following that guide. But I get the same error message after typing "arch-chroot /mnt /bin/bash" but with a different libncurses. – ericgramirez Sep 28 '15 at 23:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.