2

Yesterday I installed Linux Mint (17.2) on my HP Pavilion m6-1035dx and I'm experiencing problems with my sound.

The laptop has 2 speakers and a subwoofer (Beats audio). Only the right speaker works. I checked with the sound app (Sound test).

After exploring I found a relevant article on linux.org about Beats Audio issues on similar laptops.

I downloaded the HDA-jack-retask tool and tried to override the ports. The setup in the article is the same as the setup this post from unix.stackexchange and it did not work for me.

I run the command from the article:

wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh

and the output can be found here.

I don't know how to read the document. Any helps is appreciated.

3
  • Just to be clear, you previously had sound working on the system (e.g., under Windows) before installing Linux Mint?
    – derobert
    Sep 28, 2015 at 17:18
  • Yes, it was working on Windows 7 ans 10 Sep 28, 2015 at 17:19
  • I'm not sure if it's related, but I killed pulseaudio not so gracefully on an Intel HDA laptop from HP and the card got stuck in an inconsistent state. I don't remember what it did to fix it, but even ALSA broke related to a pulse state problem. Just putting it out there that the problem might not be alsa. Sep 28, 2015 at 21:08

1 Answer 1

0

Solution (for Ubuntu 14.04.4 but should work on Mint too) is:

To enable the subwoofer:
Install alsa-tools-gui.
Launch hdajackretask.
In the window that comes up, check “Show unconnected pins” in the upper right-hand side.
Scroll down and find “Pin ID: 0x10” and under that do the following:
Check the “Override” checkbox.
Select “Internal speaker (LFE)” in the pop-down menu
Click “Install boot override” button in the lower right-hand side.
Restart PC.

Source

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .