-1

This question already has an answer here:

I got an alert stating that 3 of my mount points are 91 % full and i need to clear the files. When I run df -h command it states that the mount points are 91% full but when i try to run du -sh * in the directory where i want to clear file it does not show me much of space occupied hardly 1 GB. Further when i run find /mount-point -xdev -size +100000000c -exec ls -lhtr {} \; it dose not provide a satisfactory output in terms of file size.

Can you help me out to find the solution for the above? What i thought is that finding the list of open files for that mount point and then kill the PID so that if any dead files consuming space may be cleared out, but i am not able to find a method to do that.

(Cant find the syntax of fuser and lsof in solaris 10 to do this)

marked as duplicate by Archemar, dr01, Gilles, Anthon, dhag Sep 28 '15 at 12:55

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Which files that need to be cleared does the alert refer to? Your question can be answered by "Yes, I can help" or "No, I can't help" how is that going to help you? We have to sing (<=cant) "find the syntax of fuser and solaris" to do what exactly? – Anthon Sep 28 '15 at 12:12
  • You should ask for your question to be reopened and provide the solution you found (go to the global zone to cleanup the file system where the lofs mount is pointing) as your self-accepted answer. Your question is marked as a duplicate of another question but that other question doesn't specifically address your case. – jlliagre Mar 4 '16 at 23:48
0

This will search via all the processes with unlinked open files. Find the ones that match your paths and removed them.

lofs does not exist in Solaris by default.

find /proc/*/fd -type f -links 0 -exec ls -lrt {} \;
  • 1
    Lofs was initially developed on SunOS-3 and later ported to various other platforms. As for any other OS, it is a free add on. – schily Sep 28 '15 at 9:58
  • Hey Guys i solved the answer for above, Thanks for the help. It looked like the file system on which the alert came was mounted as loop back type. Hence i had to go to the Global Zone and delete the unwanted files over there Thanks everyone for the efforts .:) – Raghav Chadha Sep 28 '15 at 14:00
  • lsof does exist by default in Solaris and it is often used, especially when non global zones are present. – jlliagre Mar 5 '16 at 0:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.