1

After doing a system upgrade, whenever trying to use php it complains:

php: error while loading shared libraries: libncursesw.so.5: cannot open shared object file: No such file or directory

Sure, it's because I now have libncursesw.so.6

Any workaround?

  • I installed PHP from source. I deleted all the files but I still get the same error message. – ericgramirez Sep 28 '15 at 7:16
  • ncurses in arch is now version 6, you'll need to recompile your PHP installation to link against the new library files. – Wieland Sep 28 '15 at 14:49
1

I had not upgraded my Arch server in a few weeks: ncurses has indeed changed to version 6 as of early September, but PHP should have been upgraded with it.

The quick-n-dirty fix is: pacman -U /var/cache/pacman/pkg/ncurses-5.9-7-i686.pkg.tar.xz

You can install PHP via pacman. There'a a number of pieces that I've found necessary, including php, php-apache, php-gd, php-sqlite. If you're compiling PHP from source to stay at a particular version, I'm not sure that's a good idea as PHP gets patched a lot. It would be hard to keep up with the security patches compiling everything yourself.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.