3

I have a funtoo installation and I recently did sudo emerge x11-misc/lightdm which appeared to work fine, but attempting to start lightdm in test mode with sudo lightdm --test-mode gives this:

** (lightdm:12656): WARNING **: Failed to get list of logind seats: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.login1 was not provided by any .service files

This is strange because I (think) am using openrc, not systemd (which I believe provides logind).

I don't think systemd is installed because equery f systemd says No installed packaged matching systems and I wish to keep it this way. Is it possible to configure LightDM to not use systemd?

  • I think am having the same problem as you. On my system, lightdm installs fine but sudo lightdm --test-mode gives me the same warning as you got. But beware: it really is a warning, not an error. So it is possible you can find more clues in /var/log/lightdm/lightdm.log. Could you edit your post to include the contents of this file? Also, can you tell us which of these USE flags you have enabled systemd introspection gnome? And which profile do you have enabled? – Wilson Oct 12 '16 at 18:29
  • Is it possible to configure LightDM to not use systemd? Unlike a certain other DM, LightDM does not need systemd to function. – Wilson Oct 12 '16 at 18:40
0

In my case, because I did not have pantheon installed, the problem with lightdm not starting up was to remove the enlightenment overlay and then to install the ebuild supplied by Gentoo themselves.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.