0

I am currently having an issue which is preventing me from editing the group permissions for my '/media/rnetBackup/' directory. I have tried editing the permissions using nautilus and using

chgrp -R rnetshare /media/rnetBackup

but it doesn't have any effect. Any suggestions?

closed as unclear what you're asking by Gilles, hildred, G-Man, Anthon, X Tian Sep 27 '15 at 9:14

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Please edit your question and i) tell us what filesystem you are using; ii) show us the output of ls -ld /media/rnetBackup before and after running the chgrp command. – terdon Sep 26 '15 at 20:23
0

Use chown instead of chgrp. The syntax is chown [OPTION]... [User]:[Group] file.

For your case, you could do: chown -R root:rnetshare /media/rnetBackup

0

You could try checking if the attributes of the directory are correctly set. For this, first do lsattr. It should give some output like this:

----i--------e-- /media/rnetBackup

If there is the character i in your output, it means the folder can not be edited. Just change the attributes in this case and it will be working fine:

sudo  chattr =e /media/rnetBackup

Not the answer you're looking for? Browse other questions tagged or ask your own question.