1

I have a remote machine at IP address xxx.xxx.xxx.xxx, and a local machine. I've set up the export file on the remote machine to export /ShareDir.

On my local machine, I can run mount xxx.xxx.xxx.xxx:/ShareDir /mnt/MountShareHere just fine. I can go into /mnt/MountShareHere and see everything from /ShareDir in it.

Now I want to mount a directory from inside /mnt/MountShareHere to the local filesystem. First I tried mount /mnt/MountShareHere/Subdir /mnt/MountSubdirHere which returned mount: you must specify the filesystem type. So I tried mount -t nfs /mnt/MountShareHere/Subdir /mnt/MountSubdirHere, which gave me mount.nfs: remote share not in 'host:dir' format.

I could just mount Subdir the same way I mounted /ShareDir (using the IP address and the path to Subdir on the remote machine), but I'd rather not (I'd have to rewrite some scripts and I'm lazy). Is there a trick to this? If not, what's the reason this can't be done?

2

You should be able to do a --bind mount:

sudo mount -B /mnt/MountShareHere/Subdir /mnt/MountSubdirHere

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.