I am trying to set up hourly rsync beetwen my local machine and remote server. I have already created a ssh certificate to enable login less connection to remote machine.

Now however when I execute the following command from my root account:

rsync -avzhep /home/  vps:/

I got the following error:

rsync: Failed to exec /home/: Permission denied (13)

This seems strange to me as I am root and i can normally access /home/ directory.

Could you please advice what am I doing wrong?

1 Answer 1


-e option is used to run a different remote shell, actually you are trying to execute "/home/" which is not permitted. Try :

rsync -avzh /home/  vps:/

By the way :

The "/" at the end of /home/ indicates that you want to copy the content of /home to the remote root directory ("vps:/"). If your target is the remote "/home" directory, you should use :

rsync -avzh /home/  vps:/home


rsync -avzh /home  vps:/
  • 1
    How Can I rsync with port specific remote ?
    – Nisam
    Jul 1, 2016 at 5:05
  • 1
    Port is only working when -e is present , Please get me a clean solution
    – Nisam
    Jul 1, 2016 at 5:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .