0

When I upgraded to Ubuntu 14.04 it also upgraded cifs. In Ubuntu 12.x a network mount script I had would nicely mount a Windows network share as read/write. My attempts at updating it to work with the new cifs have failed, see syntax attempted below which results in a read-only mount for my non-root account. Note that even after making mount path 777/user:user the following results in the mount path changing to 755/root:root.

sudo /sbin/mount.cifs $SHAREPOINT $MOUNTPOINT -o username=$user dom=$domain forceuid=$user forcegid=$user dynperm file_mode=777 dir_mode=777

  • shouldnt there be commas instead of spaces between your various options? – meuh Sep 23 '15 at 17:09
0

You want to pass uid=user as a mount option. My /etc/fstab contains something like

//server/share  /home/user/win/H  cifs  uid=user,credentials=/home/user/.smbcredentials,iocharset=utf8,sec=ntlm 0 0 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.