2

I'm trying to convert a video changing the audio codec from aac to ac3_fixed:

avconv -i input.mkv -c:v copy -c:a ac3_fixed output.mkv

However this commands aborts after showing the following output:

avconv version 11.2-6:11.2-1, Copyright (c) 2000-2014 the Libav developers
built on Jan 18 2015 05:12:33 with gcc 4.9.2 (Ubuntu 4.9.2-10ubuntu2)

...

Duration: 02:01:58.27, start: 0.000000, bitrate: N/A
Stream #0.0: Video: h264 (High), yuv420p, 1916x804 [PAR 1:1 DAR
479:201], 23.98 fps, 1k tbn, 47.95 tbc (default)
Stream #0.1(spa): Audio: aac, 48000 Hz, 5.1, fltp (default)
Stream #0.2(spa): Subtitle: [0][0][0][0] / 0x0000
Stream #0.3(eng): Subtitle: [0][0][0][0] / 0x0000

Stream #0.0: Video: libx264, yuv420p, 1916x804 [PAR 1:1 DAR
479:201], q=2-31, 1k tbn, 1k tbc (default)
Stream #0.1(spa): Audio: ac3, 48000 Hz, 5.1, s16p, 448 kb/s (default)
Metadata:
  encoder         : Lavc56.1.0 ac3_fixed
Stream #0.2(spa): Subtitle: ass, 200 kb/s
Metadata:
  encoder         : Lavc56.1.0 ass
Stream mapping:
Stream #0:0 -> #0:0 (copy)
Stream #0:1 -> #0:1 (aac (native) -> ac3 (ac3_fixed))
Stream #0:2 -> #0:2 (? (?) -> ssa (ass))
Error while opening encoder for output stream #0:2 - maybe
incorrect parameters such as bit_rate, rate, width or height

I guess the problem is related to the encoding of the subtitles, but I don't know what is necessary to fix it. I couldn't find any information on the internet about this issue.

Any help is greatly appreciated,

1

Maybe specifying to avconv you dont want to convert your subtitle with -c:s copy will solve your issue.

I dont no what's the default behavior...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.