0

After getting fed up with Ubuntu because it wouldn't boot grub, I decided to use the distro Elementary OS. Elementry OS won't boot grub either.

I'm not dual-booting, and I've installed Ubuntu in the past. I've tried formatting my drive, deleting the partitions then using the option "Erase disk and Install distro". The distro successfully installs, but grub just doesn't want to install/boot. I only use one hard drive.

I tried using boot-repair, but when it tells me to restart, I restart and it doesn't fix the problem. I tried installing grub command-line as well, but I alway get errors. Here's an example:

Installing for x86_64-efi platform. grub-install: error: cannot find EFI directory. Here's my bootinfo - http://paste2.org/FWpH0Dvc.

  • Your log states: No boot loader is installed in the MBR of /dev/sda. – eyoung100 Sep 23 '15 at 1:47
0

Although you hoped to escape Ubuntu's boot and grub problems by trying another distro, coincidentally what you chose,

Operating System:  elementary OS Freya 

is actually still "Based on Ubuntu 14.04 LTS". There seems to be lot of questions around 14.04 boot and grub problems -- Another recent post by an Ubuntu 14 user just a few hours apart from yours also has No boot loader is installed in the MBR of /dev/sda.

Since it seems to be a Ubuntu 14.04 issue, and plenty of others have had problems with 14.04, maybe one of the 14.04 solutions on Ask Ubuntu might help, eg http://ubuntuforums.org/showthread.php?t=2272927&p=13261862#post13261862

  • What's funny is I went to AskUbuntu first and they told me come here. I'll use another distro and see if it fixes the problems. – MadC Sep 23 '15 at 14:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.