4

I have a Lenovo Thinkpad L440.

  • Core i7
  • 4GB RAM
  • 1TB HDD
  • Windows 7 64 bits installed though right now it has Windows 10.

I made space in disk to install Linux Mint. Left:

  • 20~ GB for /
  • 8~ GB for swap
  • and almost 195~ GB for /home folder.

Installed Linux Mint 17 (64bits) with Cinnamon as desktop environment and everything was quite smooth... Until I started noticing how the boot process was taking too much time.

Mint was always up to date so I do the usual stuff to accelerate boot time.

First Kernel Panic

One day, it took too long to boot and a kernel panic message appeared.

Tried to fix it using boot-repair but it didn't work. 'Googling', I found some commands to mount /dev/sdax partition but none of them worked for me. Finally, I gave up on everything, cleaned the partition from Windows and reinstalled Linux OS but this time it was Linux Mint 17.2 (64bits).

Second Kernel Panic

This time it took less time to occur. Just a few days later, a kernel panic message appeared again. It followed the same patron as in the same kernel panic. Boot time took so long and then some day the kernel panic message.

Again, boot-repair nor any command issued as root (from a live cd) could help me.

Cleaned the partition again from Windows and installed Ubuntu 14.04 (32 bit)

Third Kernel Panic

Ubuntu booted normally but it took hours! for the kernel panic message to appear.

Again, cleaned the disk partition and as I had no more OS available, used Linux Mint 17 again.

This is the Kernel Panic message I got every time.

kernel panic lenovo thinkpad l440

--

From this point now, I started to think it could be due to a hardware incompatibility so, looked for a BIOS update for my computer. Fortunately, I found an update for my Thinkpad and updated the BIOS.

Linux Mint was running good until recently I started noticing the boot time issue.

A few weeks ago I had a booting issue, however, the recovery mode let me fix the linux mount and partition and everything was fine.

I really don't know what to do or what could be the cause of all this whole thing in my computer.

  1. What could I do to try to fix this?

  2. What could be causing this problem with several Linux versions?

  3. Could it be a hardware incompatibility with my pc?

Thanks a lot!

UPDATE: 03/10/2015

After a long time using Linux Mint again, a new problem appeared.

One of the messages in the error screen that got my attention is:

EXT4-fs error (device sda6): __ext4_get_inode_loc:3910 inode #1193206: block 4719759: comm fsck.ext4: unable to read itable block Superbloque last write time is in the future. (by less than a day, probably due to the hardware clock being incorrectly set).

Later, a prompt asked to correct some errors and after long hours the machine would boot again into Linux Mint but now X Server wouldn't start.

Fifth Kernel Panic

Tried to install Linux Mint 17 without making partitions /, /swap and /home but with the default installation where it auto-allocates the space needed.

It took seconds for the installation process to finished when the machine immediately showed me a Kernel Panic error (very similar to picture above).

Sixth Kernel Panic

Tried this time with Elementary OS Freya, the installation seemed to be completed but when booting the pc went straight to Windows 10. Tried to fixed the GRUB with Boot-Repair but nothing happened (Boot-repair wouldn't give me the option to actually repair anything). Tried the command mount /dev/sda6 /mnt but didn't work because a Can't read superblock which I've seen before as well.

  • Next time the kernel panics (or if you still have the old ones) save the output and add it to this question. It is likely a specific driver mis-behaving on your hardware and the information contained in the kernel panic is the only way you are likely to get a correct answer from this question. – casey Sep 22 '15 at 14:13
  • @casey I think I have a picture of one the messages. Will post it as soon as I can. Thanks. – Francisco Sep 22 '15 at 15:27
  • From that output it looks like your root fs isn't being found or mounting fails or something else is wrong with it. Can you capture the boot logs? – casey Sep 23 '15 at 0:03
  • @casey when the first Kernel Panic appear I was able to use boot-repair and it gave me these results: paste2.org/1WAMxLBa – Francisco Sep 23 '15 at 1:06
2

Try this, update chroot mode.

  1. Boot live with usb or anything
  2. Mount root partition, type following commands

     sudo mount /dev/sda7 /mnt
     sudo mount --bind /dev /mnt/dev
     sudo mount --bind /sys /mnt/sys
     sudo mount --bind /proc /mnt/proc
    
  3. Now move to initial chroot environment, give this commands

     sudo chroot /mnt
     apt-get update
     apt-get upgrade
     exit
    
  4. Unmont the chroot mode, by typing this

    sudo umount /mnt/proc
    sudo umount /mnt/sys
    sudo umount /mnt/dev
    sudo umount /mnt
    

I hope it works

  • Right now, the Mint version I have installed have another issue. However, the first time I got the Kernel Panic, I tried these commands and they didn't succed. They were one of the solutions tried. What do you think about the other two questions inside the main question? Thanks anyway. – Francisco Oct 1 '15 at 22:44
  • when I type the command sudo mount /dev/sda6 /mnt I get error message "mount: /dev/sda6: can't read superblock". Which lead me to another point in where I haven't found a solution that works for me. – Francisco Oct 4 '15 at 4:32
1

All this was about a bad hard drive. Don't know how or when but it got bad. Asked Lenovo support for a replacement, got it and it's been working since.

  • The errors pointed to it TBH. Good thing it is solved now. – Rui F Ribeiro Feb 11 '18 at 3:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.