6

A few days ago, I found out that the O key on my keyboard doesn't work. I have seen a few similar topics with this problem, but none of them seemed to be solved.

  • When I tap the key - nothing happens.

  • When I hold it - outputs "oooooo".

  • When I use Shift - "O".

  • And when I turn Caps Lock on and hold Shift - "o".

It doesn't even work when I am using a USB keyboard either. From what I have read, it seems to be an issue with Compiz, window manager of Unix. However, I did not manage to find the solution to this problem.

Is there anyone who encountered the same issue or/and manage to solve it?

PS: I'm using Ubuntu 14.04 LTS.

PPS: This is the output of xev when I press the O key:

FocusOut event, serial 37, synthetic NO, window 0x4000001,
mode NotifyGrab, detail NotifyAncestor

FocusOut event, serial 37, synthetic NO, window 0x4000001,
mode NotifyUngrab, detail NotifyPointer

FocusIn event, serial 37, synthetic NO, window 0x4000001,
mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 37, synthetic NO, window 0x0,
keys:  2   0   0   0   1   0   0   0   0   0   0   0   0   0   0   0   
       0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   

KeyRelease event, serial 37, synthetic NO, window 0x4000001,
root 0xc6, subw 0x0, time 2214796, (177,133), root:(2162,185),
state 0x10, keycode 32 (keysym 0x6f, o), same_screen YES,
XLookupString gives 1 bytes: (6f) "o"
XFilterEvent returns: False
7
  • 1
    Does it work in your virtual-terminal? That'd rule out compiz and the window manager. Switch to the terminal by pressing Ctrl-Alt-F1. You can switch back to your normal desktop by pressing Ctrl-Alt-F7, or sometimes F8 or F9.
    – alienth
    Sep 22, 2015 at 12:35
  • 1
    I just tried it and it DOES work in the virtual terminal. Any suggestions?
    – Dom
    Sep 22, 2015 at 12:55
  • You probably ought to mention what desktop environment and distro you are using.
    – ams
    Sep 22, 2015 at 13:01
  • 2
    it seems your O letter is a shortcut to some action and is catched by your wm
    – netmonk
    Sep 22, 2015 at 13:10
  • 1
    Have you tried booting a LiveCD to confirm its not a hardware problem? Sep 22, 2015 at 22:34

8 Answers 8

4

I'm going to guess you're using the Unity desktop, since that's the default for Ubuntu and uses Compiz.

Click the gear icon, top right, and "System Settings". Then select "Keyboard" from the hardware section.

In the keyboard settings window, you want the "Shortcuts" tab (not the default one with speed sliders).

Search the categories for a key mapping that is assigned to "o".

If you don't find one there then it could be Compiz itself, but you'd know if you'd been messing with the settings in there, so it seems unlikely. Anyway, the configuration tool is called "CompizConfig Settings Manager", and is not installed by default.

If all else fails, delete (or move) your .compiz directory, and/or your .config/compiz settings. It might also be in the equivalent unity or gnome settings in .config or .local/share, but exercise extreme caution in those folders or else you'll break other applications.

6
  • I tried everything above, nothing worked though :/ i am sure that i dont have the letter "O" mapped to anything, its not mapped to anything even in the CompizConfig Settings Manager. And deleting the .config files did not help either. However, if in the CompizConfig Settings Manager I untick the option to "Enable Unity", the menu bars dissapear, but I can type "O". When enabled back again, it doesnt work anymore.
    – Dom
    Sep 22, 2015 at 14:14
  • When you deleted the .config, did you log out and back in again? I forgot to mention that ....
    – ams
    Sep 22, 2015 at 16:18
  • I did nt delete all files in cnfig, just the relevant ccsm Ones. And i rebOOted my system, sO i guess i did lOgOut and lOgged in again. Still the same:/
    – Dom
    Sep 23, 2015 at 8:28
  • guess you have to reinstall linux :)
    – netmonk
    Sep 23, 2015 at 8:34
  • If another account works fine (guest account, maybe?), then there's nothing wrong with the install. I.e. it's just your settings. You just have to find which setting is borked, and unset it. Eventually, I would just nuke my home directory, and restore my documents and .bashrc manually.
    – ams
    Sep 24, 2015 at 8:37
4

Open a terminal and run xev. Then press o on the window that appears and see what xev shows. If it's different that what you get for other keys then your keymap is most probably severed somehow.

Try running xmodmap -pk. This should show o and O at the same line.

Try switching to a console (alt-ctrl-f1) and see if o works.

Fire up a new X server with just a terminal and see if it works there:

X :1 & sleep 3 ; DISPLAY=:1 xterm & 

Open a terminal and run (copy-paste) this, after ensuring that you have xdotool installed:

sleep 1; xdotool type o ; echo

The above should narrow down your search.

4
  • 4
    Thank yOu fOr yOur answer, hOwever, nOthing wOrked. :/ xev dOesnt register my o crrectly, xmod shOws the mappings cOrrectly, "O" wOrks in the (ctrl +alt+ f1) terminal, and it dOes nOt wOrk On a new server.
    – Dom
    Sep 23, 2015 at 8:40
  • @Dom Is there a chance that you are doing this on a laptop's keyboard that has alternate mappings for the keys? Do you have any strange USB devices attached? Can you also try the xdotool test above? (just added it)
    – V13
    Sep 23, 2015 at 22:03
  • @Dom also, do you have /etc/X11/xorg.conf present? If yes, are there any settings about the keyboard?
    – V13
    Sep 23, 2015 at 22:05
  • I did not use any strange USB devices as this happened to me on my work laptop. I did not change any mapping of anything whatsoever. the xdotools did not work for me either and I just checked and i could not find the /etc/X11/xorg.conf file. I tried so many "solutions" I found online for this problem, none of them worked, so I ended up reinstalling linux and i can type "o" again haha. Thank you for your help though, its appreciated! :)
    – Dom
    Sep 24, 2015 at 10:48
2

I had exactly the same problem as the one described (except that I use Ubuntu 16.04): "o" did not work but "O" did work (I noticed later that the same happened with "z" and "Z"). I went through some forums and nothing seemed to help other than reinstalling Ubuntu... there had to be something else.

Then, I remembered that I had installed some time ago the "Unity Tweak Tool" which allows, among other things, to zoom in and zoom out your Unity desktop. Here the "Desktop magnification" option was enabled, the "Zoom in" had the shortcut "z"... and the "Zoom out" had the shortcut "o". Since "o" is way more common than "z", I only noticed that "o" did not work (in fact it was working: it was zooming out a desktop that was not zoomed in i.e. it did nothing). So I replaced the shortcuts to Ctrl+Alt+z and Ctrl+Alt+o and everything works as expected now, all letters work normally and I can zoom in and zoom out at will.

Even if your problem is not the same, the letters that are not working are probably used as a shortcut somewhere.

1

So after trying everything possible, I gave up and reinstalled Linux. However, the same thing happened to me again! I realised what caused it this time though- I was changing some system shortcuts.

I did not map 'o' to anything, but I was mapping the 'special' keys (like home button, open web browser etc.), and I found out that the 'Search' button (F10) was causing the 'o' problem, as I guess Linux does not support those custom keys?

Either way it is solved, if anyone has the same issue, just undo all changes you have made in key mappings and shortcuts and you will find the cause of the problem. :)

Thank you everyone for useful suggestions and help!

0

Also helpful to try disabling the terminal shortcuts (terminal < preferences < shortcuts < uncheck "enable shortcuts").

If that fixes it, as it did in my case, then the problem is in the terminal-specific shortcuts, not system-shortcuts. Then I went through the shortcut mapping to find the issue.

0

I have faced same issue which is similar but my 'r' key is not working.

I found there are possible option to make it work:

  • Option I: With caps lock & shift key (caps lock + shift key + r key = r)
  • Option II: killall gnome-settings-daemon
1
  • If you have further questions, please ask a new question; since you're providing an answer with the remainder of your post, I'll remove the new-question aspect of it. Thank you!
    – Jeff Schaller
    Dec 11, 2019 at 17:12
0

Definitely a shortcut problem. I installed IDEA Toolbox for setting some shell scripts and accidentally set a shortcut for opening Toolbox. Removing shortcut didn't help, but quitting the Toolbox from the Quit button on the bottom of application did the magic.

My issue was the same with letter t: Shift+T worked, also Caps Lock Shift+t.

0

had similar problem my F key would only work as Shift F, worked okay in windows, so For anyone else having this problem in Ubuntu, Goto system settings->shortcuts->Global Shortcuts, hit default button and accept changes and revert to defaults. your welcome.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.