This question already has an answer here:

Is there a possibility to disable the monitor sleep in Ubuntu server 14.04? After 10 minutes my monitor goes to sleep. I've already tried several options, from https://superuser.com/questions/152347/change-linux-console-screen-blanking-behavior/154388#154388

marked as duplicate by Marco, cuonglm, Anthon, Timo, chaos Sep 22 '15 at 9:34

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

up vote 0 down vote accepted

Do this from the console, as root:

# setterm -blank 0 >> /etc/issue

This will add the escape sequence to prevent console blanking to the file /etc/issue which is displayed before the "login: " prompt. Thus the blanking is effectively permanently disabled.

If you're leaving the screen running X, then the above won't have any effect. In that case running xset -dpms; xset s off may help, unless you're also running some other screensaver program, or if your desktop environment has its own ideas of powersaving/screen blanking/etc. so then you should investigate its settings in those areas.

  • I tried this answer but it didn't solve my problem. – thomasd35 Sep 22 '15 at 11:17
  • did you log out after doing this? – wurtel Sep 22 '15 at 12:33
  • Yes, i rebooted the system. I also added the line myself to /etc/issue but that didn't solve my problem either. – thomasd35 Sep 22 '15 at 12:55
  • Ah, are you leaving it at the GUI, i.e. the X display? Try switching to the console via ctrl-alt-F1 and leaving it there. – wurtel Sep 22 '15 at 13:37
  • I'm using xserver to display a webpage and thats when the monitor goes to sleep. – thomasd35 Sep 22 '15 at 17:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.