0

This question is an exact duplicate of:

Every time I try installing Software Center on Kali Linux 2.0. it says:

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies:
 software-center : Depends: aptdaemon (>= 0.40) but it is not going to be installed
                   Depends: python-gobject (>= 3.0) but it is not going to be installed
                   Depends: python-gobject-cairo
                   Depends: python-aptdaemon (>= 0.40) but it is not going to be installed
                   Depends: python-aptdaemon.gtk3widgets but it is not going to be installed
                   Recommends: gir1.2-launchpad-integration-3.0 but it is not installable
                   Recommends: software-properties-gtk but it is not going to be installed
                   Recommends: sessioninstaller but it is not installable
E: Unable to correct problems, you have held broken packages.

What can I do to fix this?

marked as duplicate by Stephen Harris, Mr Shunz, GAD3R, X Tian, A.B Feb 14 at 1:18

This question was marked as an exact duplicate of an existing question.

0

What this means

Essentially, this means that some programs are either not installed or are not upgraded enough.

What to do

To fix this you should run the command
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install software-center
If this does not work, then go and install/upgrade each individual dependency (e.g. sudo apt-get install python-aptdaemon)...

Not the answer you're looking for? Browse other questions tagged or ask your own question.