2

Can someone help me with this error? I've upgraded my MAC OS to Yosemite 10.10.5 and seeing this issue since.

Can't locate Thread/Pool/Simple.pm in @INC (you may need to install the Thread::Pool::Simple module) (@INC contains: /Library/Perl/5.18/darwin-thread-multi-2level /Library/Perl/5.18 /Network/Library/Perl/5.18/darwin-thread-multi-2level /Network/Library/Perl/5.18 /Library/Perl/Updates/5.18.2 /System/Library/Perl/5.18/darwin-thread-multi-2level /System/Library/Perl/5.18 /System/Library/Perl/Extras/5.18/darwin-thread-multi-2level /System/Library/Perl/Extras/5.18 .) at /Users/ankala/Desktop/sample.pl line 11. BEGIN failed--compilation aborted at /Users/ankala/Desktop/sample.pl line 11.

1 Answer 1

3

The OS upgrade overwrote the Perl binaries and modules.

Adding Perl modules to an OS distribution means that the added modules may be overridden during an OS update. A safe way is to install perlbrew first and then add the modules you want. You can easily maintain multiple Perl versions and/or reinstall all of your existing modules using a newer Perl.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .