4

I have a Logitech T650. Long ago, I encountered a problem with about 1cm of the perimeter of the trackpad being "dead" -- no POINTER_MOTION events, no clicks, nothing in any of xev, libinput-debug-events, or xinput test. Unfortunately, my mousing style mostly involves the lower-left corner of the touchpad, so this discards the majority of my input.

I found that downgrading to the 3.18 kernel reverted the problem, which suggests that it's related https://lkml.org/lkml/2015/3/23/155 -- which looks unsolved. I've now upgraded to Fedora 22 which no longer supports the 3.18 kernel.

Given the lack of output from userland tools, I assume that the issue is in the kernel driver. How can I determine which kernel driver is responsible, and what options I might tweak to restore this functionality?

migrated from serverfault.com Sep 21 '15 at 18:23

This question came from our site for system and network administrators.

3

With some email help from Benjamin Tissoires (author of the driver), I was able to resolve this. The problem is that the 3.19 kernel included changes to run the T650 in a mode where its data is interpreted by software, allowing handling of gestures and the like by the same code as for other touchpads. Unfortunately, this causes the issue I've observed as well as some changes in gesture handling. The parameter that Benjamin mentioned he would add in the thread is disable_raw_mode, which basically reverts that change at runtime.

To enable this setting,

  1. add options hid_logitech_hidpp disable_raw_mode=1 to /etc/modprobe.d/hid_logitech_hidpp.conf
  2. power off the host, remove the "unifying receiver" (the little USB dongle) and turn off the T650 (set the switch on the left so that it shows red).
  3. power on the host and go through the Linux boot process
  4. re-insert the receiver and turn the T650 back on.

I found that power-cycling the T650 itself is an important part of this process: without it, the device still has the "dead" area.

You can test for proper behavior with the evtest program; run it as root, and select the input corresponding to the "Logitech T650". If clicking on the very edge of the glass surface shows EV_KEY...BTN_LEFT, then things are working. If nothing appears, the problem is not solved.

  • I still have the dead area even with the power cycle of the T650. But this fix did return all the previous behaviours like: 3 finger swipe left/right for browser back/forward, proper clicking, proper scrolling, etc. – Rob Holmes Jul 30 '16 at 17:37
  • This solved my problem too. Thanks @djmitche. – Omid1989 Dec 17 '16 at 15:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.