I am using Arch Linux. Each time I download a TeX file, Firefox suggest me to open it with notepad (which is installed through wine). Why?

$ xdg-mime query filetype  Random-file.tex 
$ xdg-mime query default text/x-tex

(nothing appears with the second command)

$ xdg-open Random-file.tex 
Opening "Random-file.tex" with notepad  (text/x-tex)
wine: invalid directory "/home/janus/.wine" in WINEPREFIX: not an absolute path

And it opens Firefox (why?), which ask me to either download the file or to open it with notepad.

I do not want to have any app associated to x-tex. I use to download them and open in a console with VIM. I just do not understand why notepad is an option.

Nor ~/.local/share/applications/mimeapps.list nor /etc/mime.types have the word notepad on it.

I am using Mozilla Firefox 40.0.3

1 Answer 1

grep -ri notepad ~/.local/share/applications

Are you sure that this gives 0 results? Here on my ArchLinux I have few files with names starting with wine-extension that register Notepad. I suggest You removing them.

Also, for future, to disable registering wine apps You can run winecfg and perform this:

Go to the Libraries tab and type winemenubuilder.exe into the "New overrides" box (it is not in the dropdown list). Click add, then select it from the "Existing overrides" box. Click "Edit" and select "Disable" from the list, then click "Apply".

  • 1
    Amazing! That grep gave me 2 files: wine-extension-ini and wine-extension-txt. I removed them and problem solved. Also I did the trick on winecfg. Thank you for your help. Sep 21, 2015 at 19:20
  • Removing wine-extension-txt (which had MimeType=text/plain;) and restatring firefox did the trick. Cheers!
    – AstroFloyd
    Dec 8, 2015 at 7:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .