I have a dual screen setup which I've configured by running this command at startup:

xrandr --output VGA-0 --auto --right-of DVI-0

I'm running OpenSuse 11.4 with dwm as my window manager. I can post the output of any command or dump any file if you think it will help.

The problem happens when I try and run a fullscreen game. My right screen goes black and loses the signal. On the other screen, my resolution goes down and I see a magnified version of the upper left corner of my desktop (the dwm tag bar). I can hear the game audio but I can't see anything other than what I described above.

Another important thing is when this happens I need to reboot (or at least restart X) because I get no input and can't close anything.


02:00.0 VGA compatible controller: ATI Technologies Inc Juniper [Radeon HD 5750 Series]

I'm not sure how I can find what driver I'm using, but I expect it's opensuse's stock driver. When the issue happens, I can't see my mouse at all -- even if I try and move it to the upper left. Pressing Ctrl+Alt+F1 drops me to a command line login. Once I enter my information I can hear the audio again but I am in still the CLI. Alt+SysReq+S does nothing at all.


After running the game and getting "locked up", I hit Ctrl+Alt+F1 and was brought to a shell. I logged in and ran my display command and received the following error message:

X Error of failed request BadMatch (invalid parameter attributes)
  Major opcode of failed request: 150 (RANDR)
  Minor opcode of failed request: 7 (RRSetScreenSize)
  Serial number of failed request: 40
  Current serial number in output stream: 41

It looks like it's saying I've mistyped it or something, however I tried a couple times and I'm fairly certain my syntax was correct. I still tried going back to X with Ctrl+Alt+F7 and I was stuck in the same situation. I then went back to the console and killed the game's process, and went back to X to see what happened. The resolutions and screens were still messed up, however I had mouse and keyboard support and could use my browser.

  • What graphics adapter do you have (post the relevant line from lspci)? What driver are you using? How did you check that you can't input anything: does the mouse cursor still move, does anything happen when you press Ctrl+Alt+F1, does anything happen when you press Alt+SysRq+S (it should cause some brief disk access)? – Gilles Oct 22 '11 at 19:16
  • @Gilles: I've added info to my post. – n0pe Oct 22 '11 at 20:46
  • Ok, so your keyboard isn't locked up, it's probably only a display bug. If you run DISPLAY=:0 xrandr --output VGA-0 --auto --right-of DVI-0 from the command line you get after Ctrl+Alt+F1 (log in first if necessary), then switch back to X with Ctrl+Alt+F7, what do you see? – Gilles Oct 23 '11 at 0:45
  • @Gilles: Added another edit – n0pe Oct 23 '11 at 1:26
  • Thanks for the data. I have no idea why xrand isn't working. The loss of keyboard and mouse may be due to a bad grab, or it may be due to something else. – Gilles Oct 24 '11 at 0:43

I ended up being able to fix the issue by installing fglrx from the SuSE repositories. It seemed some capabilities (acceleration) were not supported in the open source version of the driver.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.