10

Almost every time when I'm shutting down or rebooting the system I get the following message before the system actually shuts down:

A stop job is running for Session 1 of user xy

It waits for 1:30min and then continues with the shutdown. I'm using Debian stretch with Gnome 3. This message does not appear in the syslog.

Any ideas?

1
  • The other question is more recent, but has more answers. It has the same answer below (literally copy-pasted) and another answer with more votes.
    – Sparhawk
    Commented Apr 30, 2017 at 9:32

1 Answer 1

0

I had the same problem, searching I found a post in a reddit forum of Arch Linux.

Here is the solution that works for me https://www.reddit.com/r/archlinux/comments/4bawf7/a_stop_job_is_running_for_session_c2_of_user/d17th3u

Install watchdog

# pacman -S watchdog

And then start the service at boot:

# systemctl enable watchdog.service

Start the service to don't see the message any more

# systemctl start watchdog.service

I create a gist for this https://gist.github.com/dianjuar/98d02af4050dc2df8ae6f18695d44ca3

1
  • 2
    This solution doesn't work for debian 9.2. I just tried it.
    – boggy
    Commented Nov 26, 2017 at 8:34

Not the answer you're looking for? Browse other questions tagged .