3

I'm using Manjaro Linux on my laptop with switchable graphic cards:

00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)

03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Venus PRO [Radeon HD 8850M / R9 M265X] (rev ff)

Here's a screenshot of the drivers section of Manjaro Settings Manager:

Manjaro Settings Manager

The above shows that bumblebee's drivers are installed, but the daemon fails:

[luke@manjaro ~]$ sudo systemctl status bumblebeed
● bumblebeed.service - Bumblebee C Daemon
   Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled; vendor preset: disabled)
   Active: activating (auto-restart) (Result: exit-code) since pią 2015-09-18 16:22:55 CEST; 29s ago
  Process: 1192 ExecStart=/usr/bin/bumblebeed (code=exited, status=1/FAILURE)
 Main PID: 1192 (code=exited, status=1/FAILURE)

wrz 18 16:22:55 manjaro systemd[1]: bumblebeed.service: Unit entered failed state.
wrz 18 16:22:55 manjaro systemd[1]: bumblebeed.service: Failed with result 'exit-code'.

During my trial-and-error I also tried to install video-catalyst driver (in window shown above). It ended miserably - after the initial startup the screen was full white. I switched to another TTY and deleted video-catalyst using mhwd.

My goal is to be able to play games on Steam. What can you recommend?

  • Bumblebee is for NVIDIA cards. It does not support ATI Radeon cards. – Peschke Sep 24 '15 at 21:03
  • I've heard that. But how to explain that driver named "video-hybrid-intel-ati-bumblebee"? – Luke Sep 25 '15 at 9:55
0

have you considered/tried primus?

https://github.com/amonakov/primus

I'm not too familiar with the whole thing, but it seems like it has replaced bumblebee in most use cases.

Looks like it is known to compile on arch so you should be able to get it functioning on manjaro

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.