0

I'm facing a strange issue, I will try to give as much details as I can. I already tried lot of things from stackexchange and ubuntuforum and nothing seem to work.

My HDD looked like this :

  • /dev/sda5 : empty partition (~90GB)
  • /dev/sda3 : Linux Mint 17.2 (~60GB)
  • /dev/sda4 : Linux Swap (4GB)

I needed to install Win7 for my work so I did on /dev/sda5, I knew that the MBR will be erased but I already did it in the past and I kept my Live USB to reinstall GRUB.

First Step

I installed Win7, reinstalled GRUB then I reboot and here start all my problems. Mint is not showing up as intended. So I boot again from my Live USB, I tried to mount Mint partition and it's empty, nothing is shown.

Second step

I removed Win7 and try to install a fresh Mint on /dev/sda5 to check if it can fix things by itself but no luck.

Third Step

I wandered from post to post on stackexchange & ubuntuforum. I tried lot of things to check superblock, partition integrity : no problem ever found.

Is the partition really empty ?

So I was left with an "empty" partition with all my data. I was sure that all was still here laying on the disk. I found the "foremost" package and used it on an image of /dev/sda3. I was able to recover some files (so i am sure all is still here) but it is very messy and there is important stuff I did not found back.

If someone know what could happened or how to get my data back I will anwser all your questions.

Thanks !

Some random facts :

  • Most of the files I am willing to get back are : txt / pdf / tex /php /python files. "Foremost" does not seem to find them
  • I never touch the partition /dev/sda3 except to create an image with "gddrescue"
  • When I tried to mount (even before messing up) Mint partition from Live USB (Kali & Mint) the disk was always empty (even if I can see that around 3GB are used in GParted)
  • I am posting from the fresh Mint install and I can run whatever command is needed and install any package required

Edit :

Result of parted -l :

Model: ATA ST9160821AS (scsi)
Disk /dev/sda: 160GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type      File system     Flags
 1      1048kB  90,0GB  90,0GB  extended                  boot
 5      1049kB  90,0GB  90,0GB  logical   ext4
 3      90,0GB  156GB   65,7GB  primary   ext4
 4      156GB   160GB   4294MB  primary   linux-swap(v1)
0

Identifying filesystem type by posting the output of the following commands as root:

pvs
vgs
lvs
parted -l
cat /proc/partitions

Good luck on your quest to finding the solution.

  • According to parted -l the filesystem type is ext4 – mckl2228 Sep 18 '15 at 17:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.