0

Edit: I have two copies of this card and when I try to make it work on an other computer with Debian 8 (freshly installed), I have exactly the same problem.

I'm trying to install a wireless network card (Asus PCE-N15) on an Gigabyte motherboard, my wire connection is working correctly, but with the wireless, I can connect to my Internet box but I have no Internet connection.

I run on Debian 8 Jessie and I have the package network-manager installed.

Firstly, the card has two LEDs but this is the orange one and not the green one which is lit. Nothing can be done physically on the wireless card (there is no button).

The card is detected as it is shown by the following command:

lspci | grep Network
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8192CE PCIe Wireless Network Adapter (rev 01)

Here is the result of ifconfig:

docker0   Link encap:Ethernet  HWaddr 56:84:7a:fe:97:99  
      inet addr:172.17.42.1  Bcast:0.0.0.0  Mask:255.255.0.0
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

eth0      Link encap:Ethernet  HWaddr fc:aa:14:21:31:56  
      inet addr:192.168.0.110  Bcast:192.168.0.255  Mask:255.255.255.0
      inet6 addr: fe80::feaa:14ff:fe21:3156/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:16042 errors:0 dropped:0 overruns:0 frame:0
      TX packets:9325 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:22390273 (21.3 MiB)  TX bytes:865780 (845.4 KiB)

lo        Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:230 errors:0 dropped:0 overruns:0 frame:0
      TX packets:230 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:37350 (36.4 KiB)  TX bytes:37350 (36.4 KiB)

wlan1     Link encap:Ethernet  HWaddr 14:dd:a9:2e:1d:74  
      inet addr:192.168.0.112  Bcast:192.168.0.255  Mask:255.255.255.0
      inet6 addr: fe80::16dd:a9ff:fe2e:1d74/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:120 errors:0 dropped:0 overruns:0 frame:0
      TX packets:153 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:18113 (17.6 KiB)  TX bytes:20839 (20.3 KiB)

Is it a problem that the wireless is on wlan1 instead of wlan0?

Here is the file /etc/network/interfaces

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

auto wlan1

As shown bellow, I think that the gateway is correctly configured, isn't it?

ip route show
default via 192.168.0.1 dev wlan1  proto static  metric 1024 
172.17.0.0/16 dev docker0  proto kernel  scope link  src 172.17.42.1 
192.168.0.0/24 dev wlan1  proto kernel  scope link  src 192.168.0.23

If I try to ping any address on my subnet I receive this:

From 192.168.0.17 icmp_seq=1 Destination Host Unreachable

If I try to ping an address outside of my subnet it seems to take an infinite time without any response.

I have now no idea of what to do in order to make it work...

  • You probably need to set the routes so that they all point via wlan1 rather than eth0. If you aren't actually wired-connected, the eth0 routes will create confusion. (If you are wired-connected, you probably want to yank the wire in order to test wireless, at least.) – Tom Hunt Sep 17 '15 at 16:38
  • Thanks for your response. I made all my tests with the wire unplugged. Can you please explain me how to set the routes? – user3581976 Sep 17 '15 at 16:42
  • I'm only familiar with the older route command, not the newer ip route. Using that, you would route del every route that refers to eth0, then route add (at least) one route for 192.168.0.0/24 through wlan1 and a default route using 192.168.0.1 as a gateway. See the man page for specific syntax. – Tom Hunt Sep 17 '15 at 16:57
  • I edited my post to show the new routes printed by the ip route show comand. Does it seem better to you now? It still doesn't work unfortunately. – user3581976 Sep 17 '15 at 17:47
  • Temporarily disable your firewall (with sudo iptables -F) and try to ping your default gateway (192.168.0.1). – garethTheRed Sep 17 '15 at 18:43
1

The line auto wlan1 only brings the interface up but doesn't configure it. That is why it's there but doesn't transmit. You should also configure it using, say iface wlan0 inet dhcp (on the next line). iface says it's an interface configuration stanza; wlan1 is the name; inet says it concerns TCP/IP traffic and dhcp says how it is to be configured. Than service networking restart to bring it up and configure it. See http://www.unix.com/man-page/linux/5/interfaces/.

  • I added this line to my /etc/network/interfaces file but without success, it still can connect to my modem but it still take an infinite time to access a web page... – user3581976 Dec 29 '15 at 16:13
0

I think I would try and edit the /etc/network/interfaces file and just change the name of the port to wlan0, if you think it's a problem.

Suspicious you don't have a wlan0? It must think something is there, maybe that's the problem. I've always referred to these as firmware, since they are at such a low level, hierarchically speaking. It might be simpler to do it this way, as I do on my Debian box. I change it in interfaces...

  • I don't think that it is a problem, I was solely asking to be sure it is not. Anyway I didn't manage to change it from wlan1 to wlan0... – user3581976 Sep 18 '15 at 13:13
0

You have two interfaces (wlan1 and another) that are both with an address on 192.168.0.*/24.

You have wlan1 defined as 192.168.0.16 but when you tried to ping you received a message from your other local interface 192.168.0.17 saying it had no route to the subnet; this is probably because it's disconnected.

Take a look at the output of netstat -i and for each of the listed interfaces check the IP addresses with ip route show. You can even do this with a little one-liner:

for intf in $(netstat -i | awk '$NF!~/L/ && $NF~/RU/{print $1}'); do echo "$intf -" $(ip addr show "$intf" | awk '$1=="inet"{print $2}' | xargs); done

If you're curious here's an expanded version of the same code that is probably a little easier to read:

# Get the list of interfaces (netstat -i) that are Running and Up but not Loopback
intfs=$(netstat -i | awk '$NF !~ /L/ && $NF ~ /RU/ {print $1}')
echo "Interfaces: $intfs"

# Iterate across the list
for intf in $intfs
do
    # Get the IPv4 addresses associated with this interface (ip addr show wlan1)
    addrs=$(ip addr show "$intf" | awk '$1 == "inet" {print $2}' | xargs)
    echo "Interface $intf has address ${addrs:-<none>}" 
done
  • Here is the result of the one-liner command: eth0 - 192.168.0.110/24 wlan1 - 192.168.0.112/24 when the Ethernet cable is plugged otherwise it is eth0 - wlan1 - 192.168.0.112/24 – user3581976 Sep 18 '15 at 13:06
  • Thus, I have indeed two addresses with an address on 192.168.0.*/24 but can you please explain me what can I do in order to avoid this? – user3581976 Sep 18 '15 at 13:12
  • @user3683807 wired ethernet takes precedence over wireless. If you're not using your ethernet connection you need to disconnect it or tell Network Manager not to assign it an address. With DHCP this should be happening automatically. Maybe you have an entry for eth0 in /etc/network/interfaces that's overriding NM? – roaima Sep 18 '15 at 13:43
  • I make all my test with the wire unplugged. That's possible, I edited my post to show what is in the /etc/network/interfaces file. – user3581976 Sep 18 '15 at 13:52
  • @user3683807 try ifconfig eth0 inet 0.0.0.0 down. A little over the top but quite effective. I don't see why NM isn't doing this for you when you disconnect the cable, though. – roaima Sep 18 '15 at 14:01
-1

First ping localhost it mast answer, the ping the gateway probably 192.168.0.1 if it doesn`t answer then you have a problem with the driver try /etc/init.d/networking restart. If nothing works change the driver. Look for it at the makers web.

  • I can ping localhost but not the gateway (it doesn't answer). /etc/init.d/networking restart doesn't change anything. Are you sure that it can come from the driver knowing the card is recognized? – user3581976 Sep 17 '15 at 19:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.