7

I installed Kali Linux 2.0 yesterday on my Zenbook UX303LB and touch-click on my track pad doesn't work. I had the same problem in Ubuntu so it's not a new issue and I just used a mouse as a workaround. However, a couple minutes ago I discovered that I am able to scroll around a website when touching the track pad with two fingers!

Why can my touch pad detect two fingers scrolls but not one simple tap? Maybe I could configure the touch pad to recognize tap clicks?

1
11

This also working for me:

synclient tapbutton1=1

If you do not have synclient in your distro (e.g. Kali), apt-get install xserver-xorg-input-synaptics, reboot, then try again. See this answer for a way to keep synaptics settings persistent between reboots.

But...

As Linux users, we usually trying to fix problems via terminal, digging in text files, and all similar complicate stuffs, but answer is much simpler this time :)

Kali Linux have an option for turn on/off "Tap to click", in /Settings/Mouse & Touchpad. This option is unchecked by default. All to need to do is check.

enter image description here

3
  • Oh wow, I feel somewhat awkward now XD That really would have saved me some time, thank you! – travisjayday Nov 10 '15 at 16:52
  • Does anyone know where this option is in Kali 2016.2 XFCE? – Aralox Mar 14 '17 at 22:07
  • Mouse and touchpad settings is not showing any options for touchpad settings but instead it consist of only mouse options.why?How can i tackle this. – Mathews Sunny Aug 13 '17 at 10:46
2

The issue has been resolved! Due to Gilles's helpful tip to check "xinput" settings, I have found I way to fix the single tap. First of I ran

apt-get install xinput

This installed xinput in the first place. Then I did a little digging and found my touch pad which had an ID of 14. I listed its properties with

xinput list props 14

I then found a property which was called "Tap Action". I noticed that its status was '0', so I checked out Synaptics's Online Manual (http://www.x.org/archive/X11R7.5/doc/man/man4/synaptics.4.html), and located the tap action thingy. To fix the problem I just had to execute

xinput set-prop 14 "Synaptics Tap Action" 1, 1, 1, 1, 1, 1, 1

I placed that into startup command so it'd run each time I logged in.

1
  • Forgive me, it's been 10 or so years since I've done any shell commands. When you say "then I did a little digging and found my touch pad which had an ID of 14", where or how did you do this? – user136110 Sep 28 '15 at 15:30
0

Add this line to xorg.conf :

Option "SHMConfig" "true"

Its work for me :-)

2
  • Thanks for th fast reply. However, I do not have a conventional xorg.conf file in /etc/X11/xorg.conf. I think mine are under /usr/share/X11/xorg.conf.d/ Those are 5 separate files though. X -configure gives me error 2 btw – travisjayday Sep 17 '15 at 15:57
  • This alone wouldn't help. It would only enable running a tool to change the configuration at runtime. – Gilles 'SO- stop being evil' Sep 17 '15 at 23:33
0

try this command

synclient tapbutton1=1

done

0

You can do it by some changes during boot in grub. Do it as follows:

1)Run

 sudo -H gedit /etc/default/grub

2) now in gedit in the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" // or may be only ="quite"

edit the above line as following

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.nopnp"

3) now save and run this command in terminal:

 sudo update-grub

4)now run the following commands in terminal:

 echo "blacklist i2c_hid" | sudo tee /etc/modprobe.d/i2c-hid.conf
 sudo depmod -a
 sudo update-initramfs -u
 echo "synaptics_i2c" | sudo tee -a /etc/modules

4)REBOOT

Thanks for pilot6 who has given the solution(copyrights@ pilot6).His solution link below:

https://askubuntu.com/questions/592925/dell-inspiron-3551-unresponsive-touchpad

link to his profile: https://askubuntu.com/users/167850/pilot6

0

To activate touchpad,

synclient tapbutton1=1

To deactivate,

synclient tapbutton1=0

it works for me.You can also do it using settings.

Go to,

Applications->settings->Mouse and Touchpad->Devices->Touchpad

And then checked(activate)/unchecked(deactivate) the button"Tap touchpad to click"

0

I'm using Kali Linux 4.14.0

cd /etc/X11
vi xorg.conf.d
**

# Example xorg.conf.d snippet that assigns the touchpad driver
# to all touchpads. See xorg.conf.d(5) for more information on
# InputClass.
# DO NOT EDIT THIS FILE, your distribution will likely overwrite
# it when updating. Copy (and rename) this file into
# /etc/X11/xorg.conf.d first.
# Additional options may be added in the form of
#   Option "OptionName" "value"
#
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
#       MatchDevicePath "/dev/input/event*"
EndSection

Section "InputClass"
        Identifier "touchpad ignore duplicates"
        MatchIsTouchpad "on"
        MatchOS "Linux"
        MatchDevicePath "/dev/input/mouse*"
        Option "Ignore" "on"
EndSection

# This option enables the bottom right corner to be a right button on clickpads
# and the right and middle top areas to be right / middle buttons on clickpads
# with a top button area.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Default clickpad buttons"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
        Option "SecondarySoftButtonAreas" "58% 0 0 15% 42% 58% 0 15%"
EndSection

# This option disables software buttons on Apple touchpads.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Disable clickpad buttons on Apple touchpads"
        MatchProduct "Apple|bcm5974"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "0 0 0 0 0 0 0 0"
EndSection

Save. After go to: Settings - Devices - Mouse & Toucpad check the option "Tap to click"

0

I am using kali linux rolling. This is what worked for me:

  1. synclient tapbutton1=1
  2. To make it persistent, copied below code from this link - https://fedoraproject.org/wiki/How_to_enable_touchpad_click to a new file named /etc/X11/xorg.conf.d/99-synaptics-overrides.conf.

    Section  "InputClass"
        Identifier  "touchpad overrides"
        # This makes this snippet apply to any device with the "synaptics" driver
        # assigned
        MatchDriver  "synaptics"
        ####################################
        ## The lines that you need to add ##
        # Enable left mouse button by tapping
        Option  "TapButton1"  "1"
        # Enable vertical scrolling
        Option  "VertEdgeScroll"  "1"
        # Enable right mouse button by tapping lower right corner
        Option "RBCornerButton" "3"
        ####################################
    

    EndSection

Not the answer you're looking for? Browse other questions tagged or ask your own question.